It's all about the answers!

Ask a question

Why does Rich Client UI show "In Progress" defects as resolved?


Harry Hoff (11) | asked Aug 20 '15, 9:27 a.m.
edited Aug 20 '15, 10:43 a.m.
The RTC process configuration is changed to consider Resolved defects not as resolved.
To achieve this the Resolved status was assigned to the "In Progress" state group:
Images does not show up in this question, so a verbal description:
In the Project Configuration->Configuration Data->Workitems->Workflow->States, the Group for the Resolved state is changed to "In Progress".

In the Web UI defects in Resolved state are correctly shown as being not finally complete.
The defect row in the plan view shows state Resolved, and the record is not striked through. If resolved items are excluded from the plan view, the record remains visible.

But the rich client UI shows the same defect incorrectly as being finally complete.
The defect row in the plan view shows state Resolved, and the record is striked through. If resolved items are excluded from the plan view, the record disappears.


Is this a bug in RTC or must something else be modified to make the rich client work as expected?

RTC Client:
Version: 5.0.2
Build id: RTC-I20141031-0926

With best regards, Harry Hoff

Comments
Donald Nong commented Aug 21 '15, 1:03 a.m.

If you mean the Eclipse client by "rich client", I've got the almost opposite result. In my RTC Eclipse Client 5.0.2, I get the correct result (strikethrough or not) straightaway after I change the state group of the "Resolved" state. But I had some problems with my browsers.

One answer



permanent link
Don Yang (7.6k2196132) | answered Aug 20 '15, 7:13 p.m.
Hi, Harry

You may go to Process Configuration > Types of Attributes and select a work item type(in which the workflow state group changed), then click on [check workflow usage in repository] menu and sync, and then check the work item again.

Your answer


Register or to post your answer.