It's all about the answers!

Ask a question

jazz uri with http instead of https


Leesen Padayachee (891594) | asked Jul 14 '15, 2:14 a.m.
 Hi

I am the uri setup stage of jts setup. My client requires a http jazz link. Do I just need to specify this here with a 9080 port? or do I need to do some other changes before this also?

4 answers



permanent link
Shradha Srivastav (34839) | answered Jul 14 '15, 2:37 a.m.

HI Leesen,

Please follow the steps mentioned in below URL to change the URI from https to http

http://www-01.ibm.com/support/knowledgecenter/SSYMRC_5.0.2/com.ibm.jazz.install.doc/topics/t_disable_server_certificates.html

By default, http gets redirected to https. To restrict that you need to follow the steps from above link and then only run through the setup and register the URI


permanent link
Leesen Padayachee (891594) | answered Jul 14 '15, 2:55 a.m.
 Hi Shradha

I have done that step, 
However, I still cannot access the jts setup with "http" ( Once I login it says: Invalid path to authentication servlet.: / ).

The jts setup still works with "https", and allows me to start the setup with the same user details I tried above.

While in the jts setup (https), I test the public URI with "http" and use port 9080, and the test is successful.

My question is, did I successfully disable security settings even though setup does not open with http? and if the test connection with "http" works on the URI step, does it mean my jazz URI will be "http://....", which is what the client and their network team require.

Comments
Shradha Srivastav commented Jul 14 '15, 3:02 a.m.

Hi Leesen,

After performing the changes you should be able to access setup URL with http.

Are you trying the steps on IE ? May be you can check on a different browser.

Also are you working with tomcat or WAS? Are there any error messages in jts.log file when you try to access with http


Ralph Schoon commented Jul 14 '15, 3:20 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

You will have to do the steps to use HTTP before doing the setup.
If you try this with an existing setup, you basically have to do a server rename, because the system has all the HTTPS references already burned in. The HTTPS/HTTP part of the URI' are part of the public URI like the port and the host name.


Leesen Padayachee commented Jul 14 '15, 3:22 a.m.

Hi


It is a new installation. I just used the previous WAS from previous install. I cleared out all the was temp and cach directories, undeployed all Jazz, and did a brand new install.


Ralph Schoon commented Jul 14 '15, 3:24 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Just wanted to make sure you are aware of the fact.


permanent link
Leesen Padayachee (891594) | answered Jul 14 '15, 3:16 a.m.
 Hi Shradha

I am using firefox on linux. Installed on WAS 8.5.0.2. Do I need to deactivate "Requires SSL" on WAS?

Can that be causing the error?

Comments
Shradha Srivastav commented Jul 14 '15, 3:21 a.m.

Yes, please disable "Require SSL" and restart the WAS profile


permanent link
Leesen Padayachee (891594) | answered Jul 14 '15, 3:32 a.m.
 that worked! Thanks

Your answer


Register or to post your answer.