It's all about the answers!

Ask a question

Receiving Error running operation saving work item


nannette Mori (50246) | asked Jul 02 '15, 1:12 p.m.

I did post this problem earlier but I need to expand on this issue.  I am receiving the error when trying to save workitem "The iteration is not from the same project area as the workitem"

Background

We are process sharing between 4 DR projects, and I have customized the attribute "Planned For" in each of the projects- not the template being shared.

For the "Planned For" attibute I need to default a value.  The value is an iteration that has been created in the timelines for each project called DR Backlog

In order to default DR backlog in the "planned for" attribute I need the DR Backlog ID number.  I use a validator script to get this ID

I associate the validator script with the "Planned For" attribute

I then create a new workitem and populate the "Planned For" field with DR Backlog

The DR Backlog id is populated in the log:

LOG:Test validatordumpIterationID:<DR BACKLOG ID Number>

I then take the DR Backlog ID number and put it in my "default value" script

I associate the "default valu" script with the "Planned for" attribute

I then create another new work item and the "DR Backlog" is defaulted

I did this process for each project because the DR Backlog ID is different for each project

This did work correctly 3 out of the 4 projects

Using the same process above I got the DR Backlog ID number and put the DR Backlog ID number into the defalt value script

However when I tried to save the work item the output below was in the log

The iteration is not from the sam project area as the workitem com.ibm.tea.workitem.common

Now if I go back again and create a new work item and select the DR Backlog from the list the work item saves.

This does not make sense because in my log it shows the same DR Backlog ID for the Backlog I defaulted and the

Dr Backlog I selected from the list.

Can you tell me what I need to do to find what the problem is?

Is there a way I can see what project area it is looking at?

I am not sure where to look to resolve this issue

Thanks!!!

Nan


Comments
Donald Nong commented Jul 03 '15, 1:23 a.m.

There are a few things you need to clarify.
1. You said the 3 out of the 4 projects worked. Does it mean that the issue appears in only the 4th project, or all 4 projects?
2. According to your description, there are no problems when you "create" a new work item, but it fails when saving. Does the "save" operation fail on both a new work item or an existing work item (in the case of modifying a work item)?
3. When you check the iteration Id, is it in the web console of the browser or the server side .log file? Make sure to check both places.


nannette Mori commented Jul 06 '15, 12:21 p.m.

answer to question number 1 - issue only appears in one project out of the 4

answer to question number 2 - that is correct

answer to question number 3 - I am not creating the work item via the web I am using the Eclipse client and I am looking at the .log file


Donald Nong commented Jul 06 '15, 8:22 p.m.

You did not answer my second question at all (it's a multiple-choice question, not yes/no question).
I suggest you also check the .log file on the server side. The web application is also based on Eclipse.

Be the first one to answer this question!


Register or to post your answer.