It's all about the answers!

Ask a question

Why Won't Artifacts Appear in the Drop-Down Menu Located in the Views/Filter Column?


1
1
Adam Cruse (5919) | asked Jun 25 '15, 2:48 p.m.
Hello All,

When I create a new artifact with an existing Type I always have to click on artifact above it, right click and follow the menu prompts. I know there's a fast and more efficient way to do this by clicking on the drop-down menu in the views/filter tags/filter attributes column but none of the artifact types (custom or original) can be found there. I checked to see if there was something in the "Manage Project Properties">"Artifact Types" that I needed to manipulate but I'm having no such luck. What do I need to do to get all my artifact types to appear in that drop-down menu?

-Adam Cruse

One answer



permanent link
Donald Nong (14.3k213) | answered Jun 26 '15, 1:10 a.m.
Your description looks a bit confusing since it starts with "creating a new artifact" and then goes on to "how to filter artifacts by types". Can you attach a screen shot showing what you want to do?

To create a new artifact, you have quite a few options.
1. Use the top menu item "Artifacts" and choose an artifact type in the "Create Artifact" section.
2. The same menu is also available in the left pane (just above the "Views" section) if you are in the "Artifacts" grid view.
3. Select an existing artifact and choose the "Create New Similar" in the context menu.

I have never encountered the problem with not seeing the artifact types in the "Artifact Type" filter. To avoid any confusion, make sure you clear all the previous filter first (use the eraser icon at the right hand side of each of the sections "Views", "Filter by Tag", "Filter by Attribute" and "Filter by Folder".

Comments
Adam Cruse commented Jun 26 '15, 8:06 a.m. | edited Jun 28 '15, 8:55 p.m.

Hello Donald,

Unfortunatly I can not, the forums require me to have a reputaion of >60 to upload pictures...

Let me be a bit more descriptive:

Your 2nd answer describes what I wish to do, however I can only select the following options:

Create Other Artifact Type

Upload Artifact

Add Existing Artifact

The "Create Numbered Heading" and "Create Normal Content" options are greyed out and I wish to know why I can't, for example, click on the menu and under the "Create Normal Content" section select "Requirement" specifically. I've seen it being done before and it just seems more efficient to me.


Donald Nong commented Jun 29 '15, 3:21 a.m.

It's still kind of confusing to me, as some of the options that you mentioned are actually available for the folder (accessing via the pencil icon on the right hand side of a folder). I'm testing with RDNG 5.0.2. Which version are you using?

BTW, do you happen to assign team ownership to any of the folders at all? Also, do the available options change when you select no artifacts, one artifact, or more than one artifacts?


1
Adam Cruse commented Jun 29 '15, 5:28 p.m. | edited Aug 30 '15, 11:08 a.m.



 I am also running RDNG 5.0.2. and it appears that changing team ownership or selecting 1 or more artifacts has no effect.
Let me try to do an example scenario:

I wish to create an artifact within a module.

In the left pane (just above the "Views" section) is a button that has its default option set to "Create Other Artifact Type".

I click on the down arrow to the right of this button and a drop down menu appears. This is the closest I can mimic what I see:



Create Numbered Heading
<none available>

Create Normal Content
<none available>

Other
Create Other Artifact Type
Upload Artifact
Add Existing Artifact




Under the option "Create Numbered Heading" should be some options if I created an artifact type that has been specified as a heading. I have made two but all I see is "<none available>".

Under the option "Create Normal Content" should be an option representing every artifact type that exists in the module besides those specified as headings. But once again all that is givin to me is "<none available>".

Instead of seeing "<none available>", I should be able to see lists of artifact types, click on one of them, and generate an artifact with the type I've selected without going through an additional tab. My question is why don't I see my artifacts types under those menus?

I hope my wording doesn't sound insulting, I'm doing my best to spell everything out because not being able to post a picture is proving to be a massive inconvience. Thank you for your help thus far.

Your answer


Register or to post your answer.