It's all about the answers!

Ask a question

How can I prevent the scm status subcommand from always requesting a password?

Mike Blake-Knox (835) | asked Jun 01 '15, 11:50 a.m.

I'm finding that I'm always being requested for a password when I use the scm status subcommand. I've tried to use scm, lscm and lscm.bat, using the login -n and -c commands in various combinations with no luck.

Here's what I see.

E:\RtcProdSandBoxes\SF>lscm login -r "" -n local -u "mbxxxxkxxx"

Password (mbxxxxkxxx @

Logged in to

E:\RtcProdSandBoxes\SF>lscm --show-uuid yes status --no-local-refresh

Password (mbxxxxkxxx @

Workspace: (1000:_2Y9C8PXDEeSGz_LVb03HhA) "TCI_CTI_Dev_mbxxxxkxxx_wk" <->(1001>

Component: (1002:_7gaFR7w5EeSd3KYw5xOn4Q) "TCI_CTI_SF_comp"

Baseline: (1003:_nlHXUrxAEeSd3KYw5xOn4Q) 2 "Snapshot for loading SF to Rele>

E:\RtcProdSandBoxes\SF>scm--show-uuid yes status --no-local-refresh

Password (mbxxxxkxxx @

Workspace: (1000:_2Y9C8PXDEeSGz_LVb03HhA) "TCI_CTI_Dev_mbxxxxkxxx_wk" <->(1001>

Component: (1002:_7gaFR7w5EeSd3KYw5xOn4Q) "TCI_CTI_SF_comp"   

Baseline: (1003:_nlHXUrxAEeSd3KYw5xOn4Q) 2 "Snapshot for loading SF to Rele>

At some point earlier today after reading that case mismatches on a username might be a problem, I logged in using a mixed case version of my userid. Subsequently, I've received a number of errors saying my lowercase name cannot login as the mixed case version is already logged in.

E:\RtcProdSandBoxes\SF>lscm login -r "" -n local -u "mbxxxxkxxx" -c

Password (mbxxxxkxxx @

Problem running

'login':Could not login to as "mbxxxxkxxx". Already logged in as

"MBxxxxKxxx". Run "lscm logout" and retry.

One answer

permanent link
Shashikant Padur (4.2k27) | answered Jun 01 '15, 11:42 p.m.
lscm login -r "" -n local -u "mbxxxxkxxx" -c
The -c option is the correct option to specify if you want to cache the password. Once the credential is cached the CLI will not prompt for the password if the operation is performed on the same repository for which the username/password was cached.

Which version of RTC are you using? I believe the case issue with username was resolved in 6.0.

Mike Blake-Knox commented Jun 02 '15, 9:42 a.m.

Thanks for confirming that the login subcommand's -c option is supposed to cache the password for subsequent uses of lscm commands.

I have tried the -c option but it didn't solve the problem. When I used login -c, the scm status subcommand still prompts for the password each time I use it.

We're using version 5.0.2.

Do you have any further suggestions?


Shashikant Padur commented Jun 02 '15, 11:38 p.m.

Can you paste the output of 'lscm list cred' command? If you have cached the credentials you should see the line with repo uri, username and the password as <password stored>.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.