It's all about the answers!

Ask a question

Getting Segmentation Fault when trying to run jbe on Linux


Enrique Gaona (13462224) | asked Jun 19 '09, 2:23 p.m.
Hi,
Not sure if this problem has been addressed in the past, since my search has returned empty. So, here goes.

When I try to run the jbe on a RHEL 4.4 Linux, the program spews out a lot of errors, with a Segmentation Fault message at the end. I just installed the build toolkit on this machine while the server is on a different machine. Any ideas how I can resolve this? Are there any missing rpm packages I need to install?

Here's the screen shot:

./jbe -repository http://rccvm05.bto.ibm.com:943/jazz -userId build -pass build -engineId ausbuildvm02 -sleeptime 5

(jbe:8388): Gtk-CRITICAL **: file gtksettings.c: line 447 (gtk_settings_get_for_screen): assertion `GDK_IS_SCREEN (screen)' failed

(jbe:8388): GLib-GObject-CRITICAL **: file gobject.c: line 1222 (g_object_get): assertion `G_IS_OBJECT (object)' failed

(jbe:8388): GLib-GObject-WARNING **: value "TRUE" of type `gboolean' is invalid or out of range for property `visible' of type `gboolean'

(jbe:8388): Gtk-WARNING **: Screen for GtkWindow not set; you must always set
a screen for a GtkWindow before using the window

(jbe:8388): Gdk-CRITICAL **: file gdkpango-x11.c: line 49 (gdk_pango_context_get_for_screen): assertion `GDK_IS_SCREEN (screen)' failed

(jbe:8388): Gdk-CRITICAL **: file gdkscreen-x11.c: line 250 (gdk_screen_get_default_colormap): assertion `GDK_IS_SCREEN (screen)' failed

(jbe:8388): Gdk-CRITICAL **: file gdkpango.c: line 150 (gdk_pango_context_set_colormap): assertion `context != NULL' failed

** (jbe:8388): CRITICAL **: file pango-context.c: line 382 (pango_context_set_base_dir): assertion `context != NULL' failed

** (jbe:8388): CRITICAL **: file pango-context.c: line 308 (pango_context_set_font_description): assertion `context != NULL' failed

** (jbe:8388): CRITICAL **: file pango-context.c: line 343 (pango_context_set_language): assertion `context != NULL' failed

** (jbe:8388): CRITICAL **: file pango-layout.c: line 208 (pango_layout_new): assertion `context != NULL' failed

** (jbe:8388): CRITICAL **: file pango-layout.c: line 782 (pango_layout_set_text): assertion `layout != NULL' failed

** (jbe:8388): CRITICAL **: file pango-layout.c: line 441 (pango_layout_set_attributes): assertion `layout != NULL' failed

** (jbe:8388): CRITICAL **: file pango-layout.c: line 605 (pango_layout_set_alignment): assertion `layout != NULL' failed

** (jbe:8388): CRITICAL **: file pango-layout.c: line 293 (pango_layout_set_width): assertion `layout != NULL' failed

** (jbe:8388): CRITICAL **: file pango-layout.c: line 2126 (pango_layout_get_extents): assertion `layout != NULL' failed

(jbe:8388): Gtk-CRITICAL **: file gtkicontheme.c: line 310 (gtk_icon_theme_get_for_screen): assertion `GDK_IS_SCREEN (screen)' failed

(jbe:8388): Gtk-CRITICAL **: file gtksettings.c: line 447 (gtk_settings_get_for_screen): assertion `GDK_IS_SCREEN (screen)' failed

(jbe:8388): Gtk-CRITICAL **: file gtkiconfactory.c: line 1098 (gtk_icon_size_lookup_for_settings): assertion `GTK_IS_SETTINGS (settings)' failed

(jbe:8388): Gtk-WARNING **: Invalid icon size 6


(jbe:8388): Gtk-CRITICAL **: file gtkicontheme.c: line 1240 (gtk_icon_theme_load_icon): assertion `GTK_IS_ICON_THEME (icon_theme)' failed
Segmentation fault

4 answers



permanent link
Nick Edgar (6.5k711) | answered Jun 22 '09, 12:20 p.m.
JAZZ DEVELOPER
It's possible that the jbe process is picking the wrong java executable to run. It should use java, not javaw. It's also possible that it's trying to open an error window because a JDK or JRE could not be found.

Try specifying the java executable directly on the command line using the -vm command line argument. I suggest using JDK that ships with the RTC Eclipse client.
For example:
jbe -vm {path_to_rtc_client}/jazz/client/eclipse/jdk/bin/java -repository ...

I recommend always specifying the JDK explicitly using -vm. Otherwise, it uses the system default JDK or JRE, which can cause various problems. For example, if it's a JRE instead of a JDK, the Ant <javac> task will fail since the JRE does not included the java compiler (javac.exe).

permanent link
Enrique Gaona (13462224) | answered Jun 23 '09, 1:24 p.m.
Thanks Nick, your suggestion of passing the java executable worked.

Up until today, I had to start the build engine bye running the command "java -jar plugins/org.eclipse.equinox.launcher_*.jar -repository https://url_goes_here:9443/jazz -userId buildid -pass buildpassword -engineId junit -sleeptime 5"

permanent link
Nick Edgar (6.5k711) | answered Jun 23 '09, 1:56 p.m.
JAZZ DEVELOPER
So is java on your path? If so, I wonder why jbe couldn't find it. Or maybe it was picking javaw instead of java. If you try pointing -vm at javaw instead of java, do you get the same failure as before?

permanent link
Enrique Gaona (13462224) | answered Jun 23 '09, 4:20 p.m.
So is java on your path? If so, I wonder why jbe couldn't find it. Or maybe it was picking javaw instead of java. If you try pointing -vm at javaw instead of java, do you get the same failure as before?


I have JAVA_HOME exported, but it was pointing to version 1.4.2. Once I changed the variable to Java 5, I didn't see the Seg fault.

Your answer


Register or to post your answer.