Saving User Failed
Hi,
We recently had our RTC 5.0 migrated from one server to another. Since then, we haven't been able to update old user profiles with the following error:
Accepted answer
Judging by the stack trace, this issue looks very similar to an old case posted on this forum.
https://jazz.net/forum/questions/52365/error-trying-to-add-license-for-user-crjaz1534e-error
Try the solution proposed there - re-sync the user data between JTS and CCM.
One other answer
Hi,
Just an update for how I resolved the issue. I had tried re-syncing the servers before, as Donald has referenced, but with no vain.
I'd been mistaken in:
- Running the command on jts not ccm.
- I had assumed that migration_importUserMapping is not supported in Repotools 5.0 as:
- migration_importUserMapping is an invalid command for jts
- As well, the repotools reference for RTC 5.0 doesn't include the migration_importUserMapping command and the reference for RTC 3.0 mentions "This command must be used only during the 2.x to 3.x upgrade. " And since I'm using RTC 5.0, I'd assumed that this command had been deprecated and I tried several combinations for importusers and re-indexing commands.
And I resolved it by running the following commands:
- repotools-ccm migration_importUserMapping fromFile=emptyfile.csv
- repotools-ccm -rebuildTextIndices
- repotools-ccm -reindex
Comments
Krzysztof Kaźmierczyk
May 06 '15, 10:31 a.m.karmah El-qadi
May 07 '15, 4:43 a.m.