It's all about the answers!

Ask a question

Build Toolkit version compatibility


Rafael Rezende (431323) | asked Apr 14 '15, 12:02 p.m.
edited Apr 14 '15, 12:16 p.m. by Spencer Murata (2.3k115970)
I'm unable to find an official documentation about the compatibility between Build Toolkits and RTC Server versions.
We've experienced version incompatibility issues between different RTC servers and clients, but no issues with Build Toolkit so far.
There is an old question here about this topic. Does the answer still applies for earlier versions (4.0.6... 6.0.0) of RTC?

Thanks in advance!

Accepted answer


permanent link
Spencer Murata (2.3k115970) | answered Apr 14 '15, 12:12 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Officially the build toolkit and server versions must match.  Unofficially we make an effort to make all the clients N-1 compatible.  There are of course exceptions where model changes happen between the toolkit and server.  However if there is a problem the toolkit will fail with an exception, nothing will be corrupted.

~Spencer
Rafael Rezende selected this answer as the correct answer

Comments
Rafael Rezende commented Apr 14 '15, 12:21 p.m.

Thank for the answer, Spencer.
So, should I assume that the N-1 compatibility is not guaranteed either?


Spencer Murata commented Apr 14 '15, 12:45 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

 You should not depend on it as we cannot predict when model changes must happen, but we avoid them whenever possible.


~Spencer

Your answer


Register or to post your answer.