It's all about the answers!

Ask a question

Is JBE v3 compatible with CLM v4.0.1


M Kevin McHugh (1547) | asked Jan 17 '13, 3:09 p.m.
I see references to "clients" being compatible at N-1 levels.  I think this would include the JBE.  But, I want to confirm that.

May I run version 3 JBE's against RTC at version 4.0.1?

Accepted answer


permanent link
Rosa Naranjo (2.8k11420) | answered Jan 20 '13, 10:24 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
edited Jan 20 '13, 10:24 p.m.
Kevin

We track information about compatibility such as JBE in the spreadsheet attached to this workitem:  Confirm supported paths for upgrading to CLM 2012 fixpacks, mod packs and CLM 2013 (218962)
M Kevin McHugh selected this answer as the correct answer

Comments
M Kevin McHugh commented Jan 20 '13, 10:33 p.m.

If I read it correctly, the answer is yes.  The N and N-1 principle holds for the JBE.

Thank you,
Kevin

One other answer



permanent link
Ralph Schoon (55.5k23642) | answered Jan 20 '13, 4:55 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
 I remember that I saw a statement, that you have to update the JBE to a matching version. If you have older servers still, you can keep the older JBEs running against them and have a parallel install of JBEs running against the newer server.



Comments
M Kevin McHugh commented Jan 20 '13, 9:23 p.m.

Ralph - do you remember where you saw that statement?

I am fairly sure you are correct.  I just want to nail it down.

Thank you,
Kevin


Ralph Schoon commented Jan 21 '13, 3:33 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Unfortunately I can't find it. I remember we had a similar discussion in this forum. Rosa is right with N-1 compatibility.

So I should reword my statement a bit: I think it is strongly suggested to upgrade the JBE's to the version of the server, as N-1 compatibility might allow the client to work, there might be newer features that it will not support.

N-1 compatibility removes the immediate urge to upgrade all clients, especially the user clients and makes upgrading easier. However, you typically have only a few JBE's and it should be easy enough to provide JBE's with a version matching the server. As noted above, you can keep the JBE's running against servers that are not yet upgrades and introduce new JBE's for the upgraded ones easily enough.

Your answer


Register or to post your answer.