It's all about the answers!

Ask a question

Issues with Test Data in RQM 5.0.2


Dolores Vogel (1031129) | asked Mar 18 '15, 1:30 p.m.
edited Mar 18 '15, 4:08 p.m.
I've noticed a couple of issues with Test Data in 5.0.2. 
1 - This Help article - https://jazz.net/help-dev/clm/topic/com.ibm.rational.test.qm.doc/topics/t_select_record_at_ex.html - says "When the application is configured to select records, the records that are selected match the data selection criteria. The data selection criteria are defined at the test case level." I don't see any place to define test data at the test case level. I only see execution variables, and I know they work differently than test data does.

2 - Although I have configured the precondition to allow everyone to select test data for test case execution, the check box is still disabled when I run a test case.

3 - On the execution panel, you can select the number of iterations that you want to test with. If you select a subset of the iterations in the test data and then use the option to automatically apply a verdict to all steps in the execution, ALL iterations show in the result record vs. only the subset that you selected. For example, I have test data with 30 iterations. I select 1-10 for execution. I apply Pass to all of them at once. My execution record shows that I passed all steps with the 30 iterations. If you apply a verdict to each step instead, the result record shows only the iterations you select.

Are these known issues? Am I missing a setup step? Do I need to add these as defects/enhancement requests?

2 answers



permanent link
Dolores Vogel (1031129) | answered Apr 16 '15, 11:00 a.m.
edited Apr 16 '15, 11:05 a.m.
 Just a follow up - I discovered the issue with the precondition. The name changed. If you use the old name, the precondition doesn't work. You have to delete the old one and add the new precondition with the new name.
Old Name: Allow Test Data Record selection before execution
New Name: Allow Test Data Selection 


Comments
Don Yang commented Apr 16 '15, 9:13 p.m.

thanks for the info.


permanent link
Don Yang (7.6k2195131) | answered Mar 18 '15, 8:41 p.m.

I am replying to 1) and 2) here. 3) seems to be a problem although I did not test it. You may want to raise a defect WI for it so that someone can confirm the behavior.

For 1), if you look at the help closely, it says:

If a test script is associated with test record data, you can configure the quality management application to select the test record data while a test case is running.
Hence you need to associate test script with test data first.
Once that is done, during running test case, you can check "Select Records from Test Data"(for 2) now)
and define the selection there:

Comments
Dolores Vogel commented Mar 19 '15, 8:28 a.m.

 The issue is that my set up is correct, and I have the proper permissions, but I still cannot select records from test data. See below.

Precondition defined Test data associated with script Option is still inactive


Don Yang commented Mar 19 '15, 7:48 p.m.

I can only see the same problem when precondition is not set. I don't find any known reports on this area for v5.0.2. It is not clear why you have the precondition for everyone but the option is disabled. You may try to restart the server, remove the precondition, run the test case, add the precondition in, clear cache/or try another browser and then run the test case again and see if that could bring the option back.

Otherwise, you may want to contact client support for further investigation. some client side trace and server log may be required.


Dolores Vogel commented Mar 23 '15, 11:05 a.m.

I finally got it to work. I had to configure a new precondition for the "Tester" role. Then, the option was active. I'm a little confused though because if the precondition to select test data is enabled for "Everyone", then I should have been able to select test data. In 4.0.7, I also have it set up for "Everyone" - my set up matches the pictures I provided earlier - and I was able to select test data without configuring it for any other roles.


Don Yang commented Mar 23 '15, 10:18 p.m.

Thank you very much for sharing the info. I don't know why  "everyone" precondition won't apply to your setting as it is a default user role for every user. In my test with v5.0.2(my above screenshot), there is no problem at all with everyone precondition setting.

Your answer


Register or to post your answer.