It's all about the answers!

Ask a question

How do you get out of the state "The server is currently in read-only mode because a migration is in progress. In order to preserve data integrity, you will not be able to make changes to the server during this time."


Jeff Ong (14113136) | asked Feb 17 '15, 11:44 a.m.
edited Feb 17 '15, 11:45 a.m.
We just restored our working production CLM 4.0.7 environment onto a test server.  However, we try to manage JTS, we get,

The server is currently in read-only mode because a migration is in progress. In order to preserve data integrity, you will not be able to make changes to the server during this time.

Any ideas how to get out of this state ?  Due to this state, Requirements Management is also not working.

4 answers



permanent link
Mike Jaworski (1.4k6) | answered Feb 17 '15, 12:11 p.m.
JAZZ DEVELOPER
Hi Jeff,

I would suggest taking a look at the JTS Setup page to see if anything still needs to be configured. The URL would be something like: https://[jtsHost]/jts/setup. Run through the steps just to make sure everything is in place. If this doesn't help, I think you might want to look into the JTS repotools command: repotools-jts -resetRepoLockId.

Hope this helps,
Mike

permanent link
Jeff Ong (14113136) | answered Feb 17 '15, 2:07 p.m.
edited Feb 17 '15, 2:08 p.m.
Hi Mike,

Thanks for replying.  We actually tried to complete https://[jtsHost]/jts/setup but got the error,

CRRRS3008E The Requirements Management server cannot determine whether the application needs to be finalized because an error occurred. The response code for the error is '503'

We tried your suggestion and used repotools-jts.sh -resetRepoLockId but the problem is still there.

> repotools-jts.sh -resetRepoLockId
Repo Tools
Provisioning using "./conf/jts/provision_profiles".
  Jazz Foundation - Core Libraries, Version 4.0.7 (RJF-I20140625-2037)

 To submit questions about issues, go to the Jazz.net forum at https://jazz.net/forum.
 To find more information about a message, see the CLM Messages Information Center at
 https://jazz.net/help-dev/CLMErrorMessages/index.jsp.
CRJAZ1363I Loading the configuration from "file:conf/jts/teamserver.properties".
CRJAZ1779I This server is configured as a JTS.
CRJAZ2558I Setting the local server rename state to false and the openServerDescriptionServiceTemporarily state to false.
CRJAZ1365I The server is attempting to connect to the following database: "//hostname.torolab.ibm.com:60004/JTS:user=xxxxxxxx;password=xxxxxxxx;"
CRJAZ1364I The connection to the following database was successful:
 Db Product Name: DB2/AIX64
  Db Product Version: SQL0907A
  Db URL: jdbc:db2://hostname.torolab.ibm.com:60004/JTS:user=xxxxxxxx;password=xxxxxxxx;
  Jdbc Driver Name: IBM Data Server Driver for JDBC and SQLJ
  Jdbc Driver Version: 4.14.121
CRJAZ1971I The server is configured with:
  Public URI: "https://compjazz.torolab.ibm.com:9443/jts"
CRJAZ2523I Setting the global server rename state to false and the validation state to false.
Reset of repository lock id has finished.

permanent link
Mike Jaworski (1.4k6) | answered Feb 17 '15, 2:14 p.m.
JAZZ DEVELOPER
Jeff,

One more option would be to try navigating to the RRC Server Migration panel. RRC might think that a migration is in progress, and you may be able to "reset" this state by navigating to that page and following any available steps. The URL should be https://[rmHost]/rm/web/projects/migration

Mike

permanent link
Jeff Ong (14113136) | answered Feb 17 '15, 3:22 p.m.
edited Feb 17 '15, 3:23 p.m.
Hi Mike,

Done that before.  We get this,


Rational Jazz Team Server (https://hostname.torolab.ibm.com:9443/rm)

The Server is Currently Not Available

This server (https://hostname.torolab.ibm.com:9443/rm) is not available for use. It is either waiting to be upgraded to version 4.0.7 or a upgrade is currently in progress.

Check with your server administrator to find out when the server will be available

Upgrade the Server

To upgrade the data on this server to version 4.0.7 format or to check on the status of a upgrade that is currently in progress, open the Upgrade Service Panel.

Open the Upgrade Service Panel

When we click on the "Open the Upgrade Service Panel" and try to do the upgrade even if we didn't do any upgrade, we get this error,

ID CRRRW7558E  The message that follows might indicate why the server does not permit the operation. To troubleshoot this issue, ask your server administrator to check the server configuration. For more information about the cause of the error, check the message details. Also, ensure that the required licenses are installed and activated, and that they have not expired. To check your licenses, from the Jazz Team Server administration pages, click Server > License Key Management. If you have correct and up-to-date licenses and are an administrator, check the fronting.properties file in the /server/conf/rm directory to ensure that the file contains the correct server name and port number. If you are not an administrator, ask a server administrator to check the fronting.properties file.
Unable to load https://hostname.torolab.ibm.com:9443/rm/rrm-migration status: 403
_6@https://hostname.torolab.ibm.com:9443/rm/web/_js/?include=D~&etag=F2WPIbt5i32_en_US&_proxyURL=%2Frm&ss=F8s3w&locale=en-us:2485:5 _6@https://hostname.torolab.ibm.com:9443/rm/web/_js/?include=D~&etag=F2WPIbt5i32_en_US&_proxyURL=%2Frm&ss=F8s3w&locale=en-us:6183:1 _13@https://hostname.torolab.ibm.com:9443/rm/web/_js/?include=D~&etag=F2WPIbt5i32_en_US&_proxyURL=%2Frm&ss=F8s3w&locale=en-us:6198:1

URL: https://hostname.torolab.ibm.com:9443/rm/rrm-migration

From migrationKey is null


Checked the userid I'm using and it has JazzAdmins permission and has a Rational CLM Solution-CLM Professonal key

Your answer


Register or to post your answer.