error upgrading RM (DoorsNextGen) from 5.0.1 to 5.0.2
Hi there,
again I'm back with an error message while upgrading.
I'm trying in our dev environment the upgrade from CLM 5.0.1 to CLM 5.0.2 and facing error upgrading RM.
The command I'm using is this:
upgrade\rm\rm_upgrade.bat -noPrompt -noStepPrompt -newJTSHome D:\ProgramFiles\IBM\JTS_v502\server\conf -oldJTSHome D:\ProgramFiles\IBM\JTS_v501\server\conf -oldApplicationHome D:\ProgramFiles\IBM\RRC_v501\server\conf -updateTomcatFiles no
The upgrade is working - connection to database is successfully and so on - but after a while he fails while adding tables (or within the post step of it).
(...)
Adding tables to the database "//jazzdev-db.rsint.net:49617;databaseName=RM_DEV;user=xxxxxxxx;password=xxxxxxxx".
CRJAZ8191W: The full-text index location is not set
CRJAZ2692I No new type handlers found for the current model versions.
The user "ADMIN" has logged in to the database "//jazzdev-db.rsint.net:49617;databaseName=RM_DEV;user=xxxxxxxx;password=xxxxxxxx".
Running post addTables for "com.ibm.team.repository"...
CRJAZ2661I The database will now be searched for private contexts missing self references. Any missing references will be repaired.
Added self references to 0 contexts in 0 ms.
Running post addTables for "com.ibm.team.repository.auth"...
Running post addTables for "com.ibm.team.process"...
Starting RM Server Migration. Current repository version set at [5.0.1]
Updating RM Storage Areas
CRJZS5650I Indices directory is D:\ProgramFiles\IBM\RRC_v502\server\conf\rm\indices
CRJZS5800I Private applications are using a transactional RDF index
CRJZS6113I Server AMU242 changed its state to primary server for asynchronous indexing.
Updating RM Project Templates
Starting RM Server Type System Migration
Error running migration
CRJAZ0683I An error occurred during the post-import handler for the "com.ibm.team.process" namespace. com.ibm.rdm.fronting.server.exception.ForbiddenException. See the log file "D:\ProgramFiles\IBM\RRC_v502\server\repotools-rm_addTables.log" for details.
Running post addTables for "com.ibm.team.jfs.resource"...
Running post addTables for "com.ibm.team.markers"...
Running post addTables for "com.ibm.team.reports"...
Running post addTables for "com.ibm.team.repository.friends"...
Running post addTables for "com.ibm.team.jfs.indexes"...
Running post addTables for "Full Text Migration Handler"...
Running post addTables for "com.ibm.team.jfs.indexes"...
Running post addTables for "Full Text Migration Handler"...
The user "ADMIN" has logged out of the database "//jazzdev-db.rsint.net:49617;databaseName=RM_DEV;user=xxxxxxxx;password=xxxxxxxx".
CRJAZ1791E The migration completed with errors. The imported database is unstable and should not be used without further analysis.
CRJZS5652I Indexing services are being shut down ...
CRJZS5651I Indexing services finished shutting down in 16 ms
(...)
Within the logfile those two errors appear:
1)
Error running migration
com.ibm.rdm.fronting.server.exception.ForbiddenException: com.ibm.rdm.fronting.server.exception.ForbiddenException
Caused by: com.ibm.team.jfs.sdk.common.ForbiddenException: CRJZS6008E User is not authorized in the specified context
2)
CRJAZ0683I An error occurred during the post-import handler for the "com.ibm.team.process" namespace.
Caused by: com.ibm.rdm.fronting.server.exception.ForbiddenException: com.ibm.rdm.fronting.server.exception.ForbiddenException
Any idea?
Thanks in advance,
Simon
2 answers
Hi Simon -
I often hit "ForbiddenException" if I do not have the correct licenses. I'm not exactly sure why you're hitting it here though as we removed the license check on RM upgrades back in 4.x days.
One significant change between 501 and 502 is the merge of LPA into JTS which is accomplished via an additional repotools command in the jts_upgrade script - did all go well there?
Let me know and we'll go from there - thanks!
Gail
Comments
showing 5 of 7
show 2 more comments
Please find all repotool log files (which are created while upgrading) through those links:
http://www.file-upload.net/download-9968687/derby.log.html
http://www.file-upload.net/download-9968697/repotools-rm_addTables.log.html
http://www.file-upload.net/download-9968702/repotools-rm_migration_rm_updateConfigurationFiles.log.html
http://www.file-upload.net/download-9968712/repotools-rm_version.log.html
Greetings,
Simon