It's all about the answers!

Ask a question

Uninstall Data Warehouse in RTC 4.0.3


Kegham Anbarjian (231610) | asked Nov 24 '14, 9:07 p.m.

Hello,

Does anyone know if there is a way to uninstall the Data Warehouse in RTC 4.0.3 running on Oracle 11g DB? I cloned an existing 11g RTC 4.0.3 'Production' database, and I set up the clone in a new environment. I was able to successfully connect RTC 4.0.3 to the cloned DB, inclduing connectivity to JTS, RRC, CCM, and QM, but I am experiencing problems connecting to the DW. I tried to set it up in the RTC Setup Wizard without success. I am wondering if I am missing on changing something in teamserver.properties files, as I tried different changes without success. 

My thought is to uninstall DW along with its schema and data files for VNF_32K, VNF_IDX, VSTR_32K, VSTR_IDX. I am not sure if I should also include the schemas ODM_DATA and RIS_TEMP.

Any helpful suggestion would be much appreciated.

Thanks,

Kevin

One answer



permanent link
Donald Nong (14.4k213) | answered Nov 24 '14, 9:57 p.m.
If you would like to use the existing DW (the cloned copy), you can at least let us know what problems you had when trying to the connect to the DW. You can check the teamserver.properties file for all the lines containing "datawarehouse". Alternatively, check the "Data Warehouse" section in the "Advanced Properties" page after you log on to /ccm/admin.
If you really want to "uninstall" data warehouse, check the "dropping the data warehouse" section in the below article.
https://jazz.net/wiki/bin/view/Main/MoreControlOverTheOracleDataWarehouseSetup

Comments
Kegham Anbarjian commented Nov 24 '14, 10:17 p.m. | edited Nov 24 '14, 11:57 p.m.

Hi Donald,

My apologies for missing to include the details of the problem. I guess I have been more focused on learning the procedure for a DW uninstall, rather than trying to fix the error message. 

I am attaching the error message which I am getting in the Setup Wizard. I know for fact that the syntax is correct. I am wondering if it has to do with a unique Consumer Key, which is why I thought of doing a clean DW uninstall, then re-install.

Thanks,

Kevin


Donald Nong commented Nov 25 '14, 12:07 a.m.

If it complains about the syntax, maybe you can check "I do not wish ..." to disable the data warehouse first, then re-run the setup and enter the connection information.
P.S. Is it possible that the "Database Table Space Folder" parameter is not right? It is system-dependent and likely not correct for your clone system.


Kegham Anbarjian commented Nov 25 '14, 5:26 a.m.

I have tried your suggestions, including entering the correct path for the database space folder, without success.

Thanks for the URL for uninstalling the DW. I think it's going to be my last resort.


Kevin

Your answer


Register or to post your answer.