It's all about the answers!

Ask a question

Is that possible to user Eclipse Luna with RTC client 3.0.1.6?


Chris Li (111) | asked Nov 13 '14, 8:53 p.m.
 Our company have buy some lincenses Rational Team Tools 3.X. Now I want to use Eclipse Luna in my client side. First I installed the RTC Eclipse Client 5.0.1, when I tried to connect to the server, it told me that the client and server version didn't match.

So I tired to install the RTC Eclipse Client 3.0.1.6 on my Luna. But it failed again. 

Is there any way to use Luna with RTC 3.X?

One answer



permanent link
Ralph Schoon (60.9k33643) | answered Nov 14 '14, 2:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
The client version needs to be as a max one major release version lower or equal to the server. So you can only use RTC 3.x with a 3.x server.

See the Systems Requirements for the compatible Eclipse versions: https://jazz.net/library/article/632

3.0.1.6 supports
  • Eclipse SDK 3.6, 3.6.1, 3.6.2
  • Eclipse SDK 3.5.2 [Bundled]

It is possible to use the p2 installs with newer Eclipse versions, but it does not necessarily always work.

Is there a reason why the Server is still 3.x? It is a old version. I would suggest to upgrade to 5.x.

Your answer


Register or to post your answer.