It's all about the answers!

Ask a question

Project area can't be saved 'ccm_user' licensing problem

Zaid Al-Khishman (351115) | asked Nov 11 '14, 3:39 p.m.
edited Nov 11 '14, 3:44 p.m.
I'm trying to add a new role to a project area, but I get the following error:

'Save Project Area' failed. Missing required license. An error response was received from the Jazz Team Server. Status=400. Message: CRJAZ1848E To perform the "Save Project Area" operation, the user (userid="ccm_user") must have one of the following licenses that are installed on the server: Analyst, Contributor, Quality Professional, Contributor, Practitioner, Stakeholder, Stakeholder, Developer, Contributor, Contributor, Developer for IBM Enterprise Platforms. The server administrator can assign licenses.

I've already given ccm_user all of those licenses and more as well. I've tried the minimal first, but here's a list of the current licenses that I assigned to the User ID / Username:

All of these licenses are the ones that come with the trial version.

I also tried restarting the server several times and also rebooting the system all together but that didn't work.

Info: RTC 4.0.7 server running on Redhat 6.5

Copied this from the server info section:

Build Information
Change and Configuration Management - Core Libraries 4.0.7 (RTC-I20140626-1252)
Jazz Foundation - Core Libraries 4.0.7 (RJF-I20140625-2037)
Application VM
Version 1.6.0
Vendor IBM Corporation
Name IBM J9 VM
JRE 1.6.0 IBM J9 2.4 Linux amd64-64 jvmxa6460sr16-20140416_196573 (JIT enabled, AOT enabled)
J9VM - 20140416_196573
JIT - r9_20130920_46510ifx5
GC - GA24_Java6_SR16_20140416_1614_B196573_CMPRSS

One answer

permanent link
Zaid Al-Khishman (351115) | answered Nov 11 '14, 4:21 p.m.
edited Nov 11 '14, 4:28 p.m.

Although the solution doesn't make much sense it worked:

If I log in as an administrator and try to create project areas / modify them I get the error that you see.

However if I log in as a regular User that I created I don't get the error and everything works fine.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.