It's all about the answers!

Ask a question

Fail to import MS project xml into RTC


N Z (3622026) | asked Oct 28 '14, 9:52 p.m.
RTC 4.0.3
IE 8

We've been having problems importing MS project files into a RTC project area which consists of many types but typically Epics which are parents of one or more Stories.

To try to get to the root of the problem and in order to remove MS project from the equation, we exported a plan from RTC, and then immediately attempted to import it (we tried leaving the work items there and also tried again after deleting them).

We select Epic as the Summary task and Story as the task. When clicking Next from this dialog, we are confronted with the error:

   TypeError: 'length' is null or not an object

If we just import the stories and use Story as the Summary task and task, the import works, but obviously, we don't have the Epics.

It's rather odd that an export from RTC followed by and import would fail in this manner. Does anyone know what that error might be referring to?

One answer



permanent link
N Z (3622026) | answered Oct 30 '14, 8:47 p.m.
 We were able to resolve the problem, although it is rather bizarre!

We have a Taskboard, used to display Stories (Epics are excluded), and so the Story states are mapped to State Groups. We didn't map Epic states to State Groups. This is what was causing the problem. Mapping the Epic states to State Groups resolved the problem.

Why this would cause a problem importing is beyond me, one of the many gotchas!

Your answer


Register or to post your answer.