It's all about the answers!

Ask a question

Rational Team Concert Plan Estimate vs Effective Estimate Column


w h (191824) | asked Oct 28 '14, 6:30 p.m.
We're using RTC 5.0 and in the plan work breakdown view, we see two columns for Estimate and Effective Estimate. Effective Estimate is set to 8 HR, but Estimate displays as 28800000.  Is there a way we can change the presentation for Estimate or an explanation for what we're seeing? It becomes an issue when looking at the progress bar, which is in the "Estimate" number format of the large number (28800000).  I cannot upload an image as my rep score is too low.


2 answers



permanent link
Rosa Naranjo (2.9k11723) | answered Oct 29 '14, 10:14 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
I couldn't reproduce this in my 5.0.1 sample environment. Please open a support ticket. Is there some reason you are displaying both Effective Estimate and Estimate. My default view for plans just had Effective Estimate as a column and both columns show the same thing so it's not real useful.  Try removing the Estimate column and see if things are better.

Comments
w h commented Oct 29 '14, 10:35 a.m.

Thanks for the analysis -- when I try to remove the Estimate column in the Plan View, I do not see the option, I only see Effective Estimate column to move. 


One item I can think of is that we've developed the Process Template in 4.0.3 (and see the same behavior in there) and are using the same template within a newly deployed 5.0 CLM and also an upgraded 5.0 environment from 4.0.3, and sometimes 4.0.0.1 and 3.0.1.1.  We have mixed environment with several instances deployed.


w h commented Oct 29 '14, 10:40 a.m.

 One more thing, only seeing this Estimate and Effective Estimate columns in the Work Breakdown view. Also seeing this large number Estimate value surfacing In the aggregate resource hours calculations (Progress Report bar) on the Work Item and All Plans section, which is creating very large Estimate #'s (e.g. 2 billion of 21 billion hours for Estimate Done section)


w h commented Oct 29 '14, 12:05 p.m.

I think I see what the issue is - on the Product and Release Backlog level, I see Estimate, but in the Jazz Sandbox I see Story Points.  I recall there was a way to display the estimate instead of the story points at the aggregate levels and this is probably that setting. Any ideas to 'fix' it so it is displayed in a usable format? 


permanent link
Kot T. (1.5k11219) | answered Oct 29 '14, 12:54 p.m.
JAZZ DEVELOPER
I am not sure if this applies to your case. Could it be that the other estimate column that you see in the plan view is in fact a complexity attribute column?

As far as I know, the time spent, Estimate or any duration type attribute cannot be used as complexity attribute. There is the following work item related to this:
Restrict the attributes for selecting the Complexity attribute to not to include the work item attributes of type Duration. (267706)

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.