It's all about the answers!

Ask a question

Which BIRT version to use with CLM 5.0.2?


2
2
Denis Maliarevich (47712) | asked Oct 17 '14, 3:41 a.m.
edited Oct 20 '14, 8:23 a.m. by Jennifer Cianchetta-Riordan (2512)
The question is: what Birt version should I download to use with CLM 5.0.2 ? Particularly with Eclipse 4.4 ?

I didn't find the answer in sys reqs page: https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements
It's a pity, this information !must be! posted there, please do in for the next release.

Accepted answer


permanent link
Krzysztof Kaźmierczyk (7.4k34693) | answered Oct 20 '14, 6:54 a.m.
edited Oct 27 '14, 5:50 a.m.
Hi Denis,
If you want to write your own report, not necessary the one for CLM, then your BIRT version must be applicable for Eclipse version you use (in this case it is Eclipse 4.4).

But If you want to write any report for CLM, the situation is a bit different. According to CLM System Requirements Eclipse server (where these reports are run) is based on Eclipse 3.6.2. Therefore you must use Eclipse 3.6.2 with BIRT installed. Here are the steps I usually perform when creating reports:
  1. Download Eclipse for Report Developers from https://www.eclipse.org/downloads/packages/eclipse-ide-java-and-report-developers/heliossr2

  2. Install IES patches on top of this eclipse version from https://jazz.net/library/article/949

See also this topic: Installing BIRT tools.
Also I have noticed that you want to use CLM 5.0.2 which is not stable version yet. Are you aware of this fact?
Denis Maliarevich selected this answer as the correct answer

Comments
Denis Maliarevich commented Oct 21 '14, 6:49 a.m.

Thank you for the answer.
I want to write reports particularly for CLM.
Now I understood the reason for choosing the 3.6.2 birt version, your clarification was exactly what I was trying to get.

Currently our company uses CLM 4.x version, but we are planing to updgrade, so I wanted to know what birt version is supported in the new release. Also we should try new Jazz Reporting Service.

One other answer



permanent link
Jennifer Cianchetta-Riordan (2512) | answered Oct 20 '14, 8:22 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
For your reference, see this topic in the Information Center: Installing BIRT tools.

Comments
Denis Maliarevich commented Oct 21 '14, 6:36 a.m.

This table from Information Center is helpful:
Rational Team Concert    BIRT    DTP    EMF    GEF    WTP
Versions 4.0 and later      2.6.2    1.8.2    2.6.2    3.6.2    3.2.3

Your answer


Register or to post your answer.