It's all about the answers!

Ask a question

Try to use -repositories file for acces to 2 ccm linked server, but jbe start failed

Michel Mouchon (112) | asked Sep 16 '14, 4:57 a.m.
 we Have 

- 1 main RTC server 4.0.4 with /JTS and /ccm applications and 

- 1 "cache" RTC server 4.0.4 with /ccm2 application registered into the main server


On the Main server I've a Project area with Streams as well as developpers Repository workspaces, 1 "main" repository workspace for Bulld purpose, 1 build engine and 1 build definition "Main" based on the "continuous load - IBM i" template and the "Main" Repo wrokspace.

On the Cache server I've a project area, A repository workspace "cache" used for Build, a Build engine, and a Build definition also based on the "continuous load - IBM i" template.

my goal is to do Build from the "Cache" server : I use Continuous Build from a Repository workspace created on the Cache server that is close to the Build machine (IBM i).


So I'm trying to use the "Repositories file" feature of the JBE but I'm unable to make the jbe working. it start bu have this error : 


2014-09-16 09:01:50 [Jazz build engine] Exception occurred in build loop: Repository "" has not been configured for use in the repositories file Repository "" has not been configured for use in the repositories file










the generated repositories file is like this : 


### reporeg 0





Note that when I generate a password file it give a differrent value for the Crypted password !!! (I tried with both crypted sentences but same result).


My jbe server start sentence is this : -jobName MMO_BEREPO -repository https://main:9443/ccm  -engineID MMO_PSPWDEM0Repos  -repositories /home/michel/.jazz-scm/repositories.txt 

Note : the JBE run on IBM i


Does somebody know the Syntax of Repositories files ?

I've a doubt on the way it works: It seems the -Repository parameter indicate a repository that must be found into the Repositories file for user and Password, but my understanding of the message is that it doesn’t find it.

One answer

permanent link
Michel Mouchon (112) | answered Sep 16 '14, 9:06 a.m.
Hi Guys, 
I answer myself : 
After plenty of trials that worked partialy sometime I finaly discover a Characters Case issue. so the Build engine JBe is working now. I used One time some uppercase instead of lowercase that was the origine of my problem. Sorry, In IBM i world we don't really care the Charater Case but the Repositories file do.

I'll publish my configuration setup process to share with you such interesting use case.

Best regards

Your answer

Register or to post your answer.