It's all about the answers!

Ask a question

Cannot get all the streams by command line


samuel wang (321723) | asked Aug 28 '14, 12:49 p.m.
edited Aug 28 '14, 2:10 p.m.
I have access right to the streams, I am able to get those streams by Eclipse, but when I run command to get the stream list, I got different result, cannot get all the stream list, is there any way to set up the access right of command?  do I need to install license in the command client side?

Accepted answer


permanent link
Winston Enos (3316) | answered Aug 29 '14, 9:54 a.m.
samuel wang,

And you are positive that the cached credentials you have for the -r argument are the same ones you are using in Eclipse? You may want to logout of those credentials and perform a 'scm login' on them again just to make sure.

I can't reproduce your issue, everything works as expected for me when I use the same user in Eclipse as the cached repository credentials on the command-line.

I suppose at this point I would focus on a specific project to figure out the issue. Choose one of the Project Areas where you see all of its streams from Eclipse but not on the command-line. When you use your command pass that '--projectarea xxx' argument to isolate which streams you do and do not see from the CLI. Whichever one you do not see from the CLI, open it up on Eclipse and check the Visibility/Owned-By status of the stream compared to another that is visible from the CLI just to see if anything stands out.
samuel wang selected this answer as the correct answer

Comments
samuel wang commented Aug 29 '14, 10:09 a.m.

I closed Eclipse, logged in IE browser, I can see all the streams from the browser, but I cannot see by command line, I am sure the credential is correct, I also tried with:
lscm -u y list stream -m 1000 -r xxx  -u xxx -P xxx,  but still cannot see all the streams.

from the browser, can I see those streams which I have no access right?


samuel wang commented Aug 29 '14, 11:18 a.m.

I can get all the streams by using the parameter of projectarea, thanks.

One other answer



permanent link
Winston Enos (3316) | answered Aug 28 '14, 3:51 p.m.
samuel wang,

What command are you using? Make sure you're giving it a --maximum that is high enough, by default it returns only the first 10 streams.

Running 'scm.exe --non-interactive --show-uuid y list streams --maximum 99999999 -r MY_CREDS' successfully returns me all the streams in every project area that is visible to my my credentials for MY_CREDS.

Comments
samuel wang commented Aug 28 '14, 4:17 p.m.

the command I used:
lscm -u y list streams -r xxx -m 10000

Your answer


Register or to post your answer.