It's all about the answers!

Ask a question

Is there an issue with exporting data with OSLC links from RTC?


Radha Sastrigal (111122) | asked Jul 23 '14, 2:28 p.m.
 Using RTC 4.0.6:
Created a custom query that pulls in all defect data with columns to show the "Affected Requirement (Link to RRC artifact) and "Affected Test Result (link to RQM) and "Related Test Case (link to RQM)

While the dsiplay of query result appears fine on the UI, once extracted in a .csv format or a printable format, the data related to RRC i.e. "Affected Requirement" column shows hyperlinks instead of the actual artifact name.
While the data against RQM works fine. 
THis problem was encountered in version 4.0.1 as well where both RRC and RQM related data was displaying as hyperlinks. Looks like only a part of the problem is been fixed in the version of 4.0.6.

Please advise if this a defect or problem with the relation or any suggestions to enhance the results

Comments

Radha Sastrigal commented Jul 24 '14, 8:29 a.m.

 Neither Donald.


The files that I am exporting are not even showing the work item IDs, but actual URL that are active hyperlinks
I am unable to add a screenshot to this comment!!
The column for "Affected Requirement" shows the data with these values:
http://hd-jaz-was...... which is the URL for our RM application


Donald Nong commented Jul 24 '14, 9:45 p.m.

I thought the link might be conformed to some format and that's why I posted the two technotes. But just now I had a quick test with the JKE Banking sample project and did not see the same problem. Also, I only see "Affects Requirement", not "Affected Requirement". Not sure why the difference here.


Radha Sastrigal commented Jul 28 '14, 11:37 a.m.

I did run the query for JKE banking example "Plan items implementing requirements" and downloaded the csv file, works fine!


The lifecycle query that I am executing is "Defects affecting requirements", and the csv fails to show the name of the requirement artifact (affects requirement column), don't understand the difference either. 
Since I am unable to insert an image within this comment, what is the best way for me to send a screenshot?



Donald Nong commented Jul 30 '14, 12:57 a.m. | edited Jul 30 '14, 12:59 a.m.

I ran the query that you mentioned that it worked for me. I have a CSV with content as shown below.

"Type"    "Id"    "Summary"    "Owned By"    "Status"    "Priority"    "Severity"    "Modified Date"    "Affects Requirement""Defect"    "177"    "test"    "Unassigned"    "New"    "Unassigned"    "Normal"    "25-Jul-2014 11:40"    "373: BJ’s Wholesale Club, Inc. Internal Use Only"
If you can't post a picture here, try uploading it somewhere else and post the link here. But I would suggest you contact Support if the issue needs to be fixed in a timely manner.


Be the first one to answer this question!


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.