It's all about the answers!

Ask a question

Does and how the RRC Quick Search (Search Projects) work with strings of multiple IDs ?


long TRUONG (3654121147) | asked Jul 08 '14, 12:00 a.m.
edited Jul 08 '14, 12:04 a.m.
 In search of getting a list of artifacts by ID, (failing with filter by attribute) , tried the following, and still not sure if Quick Search support searching for multi-IDs, if so how to properly do so. So far, it has been so erratic, not in any perceptible rhyme or rhythm.
  • I tried to copy and paste 15674, 15684: Eureka, got a search list of them, though can't keep the list and had to access only 1 at a time.
  • But same technique with 15674, 15657 only showed the latter
  • None found when copy and paste 13630, 15657 (bottom), the former exists and can be queried alone.

... And stranger yet ...

Accepted answer


permanent link
My-An Nguyen (2963) | answered Jul 10 '14, 2:32 p.m.
I don't think the Quick Search is made for searching for a list of artifact IDs.

There is a limitation article about that here (the comma is included in there):
https://jazz.net/library/article/1334#00101

The results will be inconsistent due to the way punctuation and special characters are handled.
long TRUONG selected this answer as the correct answer

Comments
long TRUONG commented Jul 10 '14, 5:32 p.m.

Thx (Cảm Ơn) My-An.

It's curious that the article contradicted the defect it listed, Work Item 60581, which has been closed as fixed:

Found In: RM 4.0.1
Resolution Date: 27 Feb 2013 16:07:23
By  Connor Hindley.


My-An Nguyen commented Jul 10 '14, 5:43 p.m.

Yes, Work Item 60581 is fixed... by publishing the limitation article. There are no actual code change sets associated with the work item that was then delivered to an integration stream. Just closed with some documentation.


long TRUONG commented Jul 10 '14, 7:06 p.m.

Thx again, My-An. 

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.