It's all about the answers!

Ask a question

Are 4.x Token licenses valid for 5.0?


Anthony Kesterton (7.5k7179136) | asked Jun 24 '14, 5:07 p.m.
JAZZ DEVELOPER
edited Jun 24 '14, 5:07 p.m.
Hi

I have been running 4.0 CLM systems using a token license scheme.  If I install a 5.0 instance, and import the JazzTokens.zip file, and point to my FlexLM license server, I don't appear to be able to use those licenses. 

If I assign token licenses to a user, when I try an operation that requires a license, I get the following errors:

An error response was received from the Jazz Team Server. Status=400. Message: CRJAZ2343E The "Analyst-Token" license is incompatible with the "676dc69a-3545-4605-a738-3e28794e42d9" application that is requesting to check out the license. The license compatibility is "ConfigurationAndChangeManagement-4.0 QualityManager-4.0 RequirementsManagement-4.0 ". The application compatibility is "ConfigurationAndChangeManagement-5.0". CRJAZ2343E The "Developer-Token" license is incompatible with the "676dc69a-3545-4605-a738-3e28794e42d9" application that is requesting to check out the license. The license compatibility is "ConfigurationAndChangeManagement-4.0 QualityManager-4.0 RequirementsManagement-4.0 ". The application compatibility is "ConfigurationAndChangeManagement-5.0".

Does 5.0 require new token keys, and a new JazzTokens.zip file?

thanks

anthony

5 answers



permanent link
Anthony Kesterton (7.5k7179136) | answered Jun 24 '14, 6:33 p.m.
JAZZ DEVELOPER
To use tokens on CLM 5.0 - you need to obtain a new JazzTokens.zip file.  This is available on the Rational License Key Center.  Load this file using the License key management page, Floating License Server section and Add the new zip file.

If, like me, you had added a JazzTokens.zip file from 4.x into your 5.0 server, you need to remove the 4.0 token keys one by one in the Floating License Server section.

You learn something new each day :-)

anthony

Comments
Robert Wen commented Jun 24 '14, 8:34 p.m. | edited Jun 24 '14, 8:36 p.m.

I remember the discussion about this at Innovate.  I was a little light on the specifics :-) 


permanent link
Peter Farrell (16) | answered Jul 16 '14, 12:01 p.m.
JAZZ DEVELOPER
I wrote an article on this. The direct link to the article is: https://jazz.net/library/article/1414#87657

To find this is a bit more difficult. To get to this go to:
1) Go to jazz.net, downloads.
2) Select RDNG 5.0.
3) Click on the release notes tab.
4) In the Known Problems and Workarounds section click on the link to "workaround articles for 5.0 query"
5) Click on the 2nd article called: Workarounds: Web client and server problems in Rational DOORS Next Generation 5.0
6) The article that discusses the steps on upgrading the licenses is the first one listed: When you upgrade Rational DOORS Next Generation to version 5.0 from a release of 4.0.x, the 4.0.1 token, floating, and authorized user licenses are not automatically upgraded

Comments
Peter Farrell commented Jul 16 '14, 12:15 p.m.
JAZZ DEVELOPER

That is for RDNG licenses. If you run the Interactive Upgrade Guide, there is a section called Version 5.0 and licenses. In that section you have information on how to upgrade your token licenses to 5.0. Also note at the top of the Interactive Upgrade Guide in the Complete The Planning checklist there is a row Learn About Licensing that states:

Learn about licensing: You must obtain new licenses for version 5.0 applications. Version 5.0 applications will not work with version 4.0.x licenses. However, version 4.0.x applications work with version 5.0 licenses.


permanent link
Robert Wen (690412) | answered Jun 24 '14, 5:25 p.m.
 Yes, you will need new license keys to deploy CLM 5.0

Comments
Anthony Kesterton commented Jun 24 '14, 5:44 p.m.
JAZZ DEVELOPER

Hi Robert

Should these licenses be available on the Rational Licensing Center?  If so - the internal IBM keys do not appear to be updated to 5.0.

thanks

anthony


permanent link
Georg Kellner (840377108) | answered Jun 25 '14, 6:56 a.m.
Is this documented in the UpgradeGuide?
I think it isn't.

Can this be solved?

Comments
Diane Everitt commented Jun 25 '14, 2:12 p.m.

A request for documentation enhancement has been submitted.


Georg Kellner commented Jun 26 '14, 6:33 a.m.

Do you have a link to this defect?


permanent link
Rohit Balduwa (945411) | answered Jun 25 '14, 7:31 a.m.
Hi Anthony

Yes, you have to use the latest Jazz Activation Kit from IBM Rational License Key Center (after regeneration of the licenses) http://www-01.ibm.com/software/rational/support/licensing/.

Additional Note : For user's using TOKEN's, only the Jazz Activation Kit needs to be re-imported on the JTS.
Once, the licenses have been returned and regenerated, extract the file and check for version v5.0 of the entitled products listed.
Also, note that user's using V5.1 of JTS also would work fine with the V5.0 licenses and no additional licenses needs to be imported.

Regards,
Rohit

Your answer


Register or to post your answer.