It's all about the answers!

Ask a question

What setup is needed to create RPE report resources for CCM/QM 4.0.2?


Jamie Berry (14013078) | asked May 15 '14, 7:32 p.m.
We are developing several RPE scripts to extract data out of RTC and RQM and are interested in creating report resources so our users can generate the reports from within RTC.  Looking at IBM help, it doesn't seem to be that hard, but whenever I try generating a report based on an RPE report resource, I receive an error:

Could not load template C:\Windows\TEMP\reports_....../template.dta Error is:

(no error listed).

Is there something we need to configure on the CCM or RQM server side to enable RPE report generation?  I couldn't find any documentation describing setup.  What version of RPE is supported with RTC 4.0.2?

We can generate the RPE based reports that come with RM, but haven't been able to upload and run any custom templates for RTC or RQM.

Thanks in advance for any help/pointers.

Jamie.

2 answers



permanent link
Subramanya Prasad Pilar (4.5k14) | answered May 15 '14, 11:07 p.m.
Hi Jamie,
You need not configure anything in CCM or RQM server. You can use any version of RPE Studio (for example, RPE 1.2.1 Studio) and create a template (.dta file). You also need to do metadata configuration for the data sources / variables before you upload it (using create resource option) into RQM or RTC.
You can refer these:
http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m2/topic/com.ibm.rational.rrdg.usage.doc/topics/t_author_docstyle_report.html
https://jazz.net/library/article/1137

If you still face issues/get errors, you can mail your .dta file to me so that I can have a look.

Regards,
Prasad (subprasad@in.ibm.com)

Comments
Subramanya Prasad Pilar commented May 16 '14, 12:37 p.m. | edited May 16 '14, 1:09 p.m.

Please set Template Version to "Template version 1 (RPE 1.2.2.2 and older)" while creating the template. As Alanna Zito mentioned, version 2 template does not work with 4.0.2.


Jamie Berry commented May 19 '14, 12:14 p.m.

Thank you for the responses.  Part of my problem was the template version.  I made a new template with version 1 and things are better.  I am still having problems getting things to run correctly.  When we run templates against CLM, we have to use OAuth for our authentication.  When running the RPE template from RTC, I am now getting the following error:

Can not redirect to the OAuthentication identify URL.  If I take the URL that is included in the error output to a browser, it works fine.  How can I get around the OAuth issue?  I don't see anyway to configure the data source to use OAuth in just the .dta file.  Do I need to associate a .dsx file that is configured for the server?

Also, I have tried to configure a variable to have the user supply a work item id.  I set the configuration metadata to try and let the user browse for a work item ID, but that doesn't seem to be working (probably the OAuth issue)

Thanks again for the help,
Jamie.


Subramanya Prasad Pilar commented May 19 '14, 1:01 p.m.

Does the template contain Data Source Configuration elements? To run a template containing dynamic data sources, you need to do some additional configuration.  This is documented in the CLM help.


Subramanya Prasad Pilar commented May 19 '14, 1:03 p.m.

-Add a non-dynamically configured data source to the report template to represent the application (make sure the name of this data source does not start with an underscore - "_")
-When you upload the template into CLM, this data source will appear as a parameter of the report.  Set the value of the parameter to the main URL of the application, e.g. "https://myserver:9443/ccm" or "https://myserver:9443/qm".

For example, suppose your template contains two data source _workItems1, which is dynamically configured, and which will access data from the RTC application.  You need to add one data source to your template, "WorkItemsApp". When you run the report in RTC, set the value of this parameter to "https://myserver:9443/ccm" (the address of your RTC server).


Jamie Berry commented May 20 '14, 2:21 p.m.

Based on conversations outside the forums, it appears my problems deal with trying to use this capability with RTC 4.0.2.  It has been recommended that I upgrade to 4.0.3 or later to utilize RPE based report resources.  We have other reasons waiting is desirable (primarily creating RPE version 2 templates and making extensive use of MS Word stylesheets).

Thank you for your support and suggestions.  Hopefully things will go smoother once we are able to upgrade.


Alanna Zito commented May 20 '14, 3:40 p.m.
JAZZ DEVELOPER

Jamie, out of curiosity, what problems do you think will be resolved by upgrading to 4.0.3?  Like you mention, it will give you the ability to create version 2 templates and use Word stylesheets on the server, but authentication for RPE templates did not change between 4.0.2 and 4.0.3 at all.


Subramanya Prasad Pilar commented May 21 '14, 2:42 a.m.

Alanna, I tried the same template provided by Jamie with RTC 4.0.5 / 4.0.6. I do not see any error and it is working fine.


Alanna Zito commented May 21 '14, 9:09 a.m.
JAZZ DEVELOPER

Subramanya, I took a quick look at the template and I don't see any reason that it wouldn't work with RTC 4.0.2.  It's a fairly simple template, with just one data source (work items), so the extra configuration you mentioned in in your earlier comment isn't necessary. 

One thing that could cause the OAuth errors in this case is if the server (i.e. ccm) is a friend of itself.  Jamie, can you find out if that's the case?


Subramanya Prasad Pilar commented May 21 '14, 1:37 p.m.

Yes Alanna. I made the earlier comments before getting the template from Jamie.

showing 5 of 9 show 4 more comments

permanent link
Alanna Zito (1.3k3) | answered May 16 '14, 11:21 a.m.
JAZZ DEVELOPER
Hi Jamie,

If you're using RTC 4.0.2, only RPE template version 1 is supported - you can still use RPE 1.2 to create your templates, but make sure to create/save them as version 1 if you want to run them on the server. If you created your templates as version 2, that may be why you're seeing an error.  Template version 2 is supported as of RTC 4.0.3.

Comments
Subramanya Prasad Pilar commented May 16 '14, 12:36 p.m. | edited May 16 '14, 12:38 p.m.

Thank you Alanna. I was not sure about the RPE/RRDG version bundled with CLM 4.0.2.

Your answer


Register or to post your answer.