It's all about the answers!

Ask a question

Jazz Build Engine Timestamp revisited


Jerry Feldman (12710) | asked May 02 '14, 4:23 p.m.
I am running Jazz 4.0.4 on a Red Hat Enterprise Linux 6 server virtual machine. I run bot the RTC eclipse client and the JBE on the same machine
All the times displayed in the RTC client are correct (EDT)
But the JBE timestamp appears to EST.
[jfeldman@bosvmjerry ~]$ date
Fri May  2 16:01:00 EDT 2014
[jfeldman@bosvmjerry ~]$ myjbe
2014-05-02 15:01:09 [Jazz build engine] Running build loop...
2014-05-02 15:01:09 [Jazz build engine] Waiting for request...

The build listing in the client shows the correct start time.

I am certain that the virtual machine is configured correctly. Also, the repository server is in the same timezone.

Comments
Mikhail Kuzmenko commented Mar 17 '17, 9:57 a.m. | edited Mar 19 '17, 6:46 p.m.

 We have the same problem. Any updates?


eclipse]$ date
Fri Mar 17 09:56:07 EDT 2017
eclipse]$ ./jbe -vm /usr/bin/java -repository https:///ccm/ -userId -passwordFile ./passwd -engineID t_main -data /data/Build/empi_usjar/code -interactive
2017-03-17 08:56:11 [Jazz build engine] Running build loop...
2017-03-17 08:56:11 [Jazz build engine] Waiting for request...


Ralph Schoon commented Mar 17 '17, 10:11 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

What are the timezone settings of

  • The machine that hosts the JBE
  • The server the JBE connects to
Is the time wrong in EDT or is just the assumed time zone wrong?


Mikhail Kuzmenko commented Mar 17 '17, 10:20 a.m. | edited Mar 17 '17, 10:29 a.m.

>>The machine that hosts the JBE 


GNU/Linux has EDT timezone
eclipse]$ date
Fri Mar 17 09:56:07 EDT 2017

>>The server the JBE connects to
We have Windows based RTC server

tzutil /g 
Eastern Standard Time


Thank you


Mikhail Kuzmenko commented Mar 17 '17, 10:26 a.m. | edited Mar 17 '17, 10:30 a.m.

All Windows hosts was shift to daytime automatically with

 <Automatically adjust clock for Daylight Saving Time> check box.
All Linux host was shift to EDT from EST recently.

It works fine in case of we start JBE on one of Windows host actually.
We getting problem with Linux hosts only.

Thank you


Ralph Schoon commented Mar 17 '17, 10:31 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 The server that hosts the JBE shows the same timezone the JBE shows - at least from the information above. So there is no surprised the JBE shows the same. Am I missing something?



Mikhail Kuzmenko commented Mar 17 '17, 10:41 a.m. | edited Mar 19 '17, 6:47 p.m.

 JBE does not show timezone actually.

Let me go back to original dump please.

Build host has EDT and current time 09:56:07
but JBE shows start time 08:56:11
This is 1 hr difference. That what let me assume that JBE still pick EST vs. of EDT, but I am not sure about it.

eclipse]$ date
Fri Mar 17 09:56:07 EDT 2017
eclipse]$ ./jbe -vm /usr/bin/java -repository https:///ccm/ -userId -passwordFile ./passwd -engineID t_main -data /data/Build/empi_usjar/code -interactive
2017-03-17 08:56:11 [Jazz build engine] Running build loop...
2017-03-17 08:56:11 [Jazz build engine] Waiting for request...

Any ideas?


Ralph Schoon commented Mar 17 '17, 10:52 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I would have expected the JBE uses the timezone of the machine.

You could try to tell the JVM of the JBE to use a specific one. Go to  JBEInstallDir\jazz\buildsystem\buildengine\eclipse and edit the jbe.ini, add 

-Duser.timezone=EDT

You can add this at the end. I have not tried that myself, but I set the user language on a regular basis. i was unable to find the values for this setting, there is no official doc page. I found similar answers on stackoverflow, so it is worth trying.


Ralph Schoon commented Mar 17 '17, 11:01 a.m. | edited Mar 17 '17, 11:02 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The java application likely uses SimpleDateFormat http://docs.oracle.com/javase/7/docs/api/java/text/SimpleDateFormat.html#timezone to print the time , so GMT+/- hour might be also a valid input.



Mikhail Kuzmenko commented Mar 17 '17, 11:28 a.m. | edited Mar 19 '17, 6:47 p.m.

 Ralph.


I did change abd here is my jbe.ini

eclipse]$ cat jbe.ini
-vm
/data/IBM/TeamConcertBuild/jre/bin/java
--launcher.suppressErrors
-vmargs
-Dosgi.requiredJavaVersion=1.6
-verbose:gc
-Duser.timezone=EDT

Unfortunately no luck:

eclipse]$ date
Fri Mar 17 11:26:33 EDT 2017
eclipse]$ ./jbe -repository https://10.118.19.57:9443/ccm/ -userId *** -passwordFile ./passwd -engineID t_main -data /data/Build/empi_usjar/code -interactive
2017-03-17 10:26:45 [Jazz build engine] Running build loop...
2017-03-17 10:26:45 [Jazz build engine] Waiting for request...

Any ideas?


Mikhail Kuzmenko commented Mar 17 '17, 11:38 a.m. | edited Mar 19 '17, 6:47 p.m.

 Correction:


eclipse]$ cat jbe.1
-vm
/data/IBM/TeamConcertBuild/jre/bin/java
--launcher.suppressErrors
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Dcom.ibm.team.filesystem.client.disable.fslistener=true
-verbose:gc
-Duser.timezone=EDT


Mikhail Kuzmenko commented Mar 17 '17, 11:40 a.m. | edited Mar 19 '17, 6:47 p.m.

 Sorry for confuse you:


eclipse]$ cat jbe.ini
-vm
/data/IBM/TeamConcertBuild/jre/bin/java
--launcher.suppressErrors
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Dcom.ibm.team.filesystem.client.disable.fslistener=true
-Duser.timezone=EDT

This is correct jbe.ini

showing 5 of 11 show 6 more comments

Accepted answer


permanent link
Mikhail Kuzmenko (162) | answered Mar 17 '17, 2:32 p.m.
edited Mar 28 '17, 7:43 a.m. by Ralph Schoon (59.4k23642)
Ralph.

Issue resolved:

 
[devusr@USSLTCSNL2483 eclipse]$ cat jbe.ini
-vm
/usr/bin/java
--launcher.suppressErrors
-vmargs
-Dosgi.requiredJavaVersion=1.6
-Dcom.ibm.team.filesystem.client.disable.fslistener=true
-Duser.timezone=America/New_York
-verbose:gc

[devusr@USSLTCSNL2483 eclipse]$ date
Fri Mar 17 14:31:59 EDT 2017
[devusr@USSLTCSNL2483 eclipse]$ ./jbe -repository https://10.118.19.57:9443/ccm/ -userId mikuzmenko -passwordFile ./passwd -engineID t_main -data /data/Build/empi_usjar/code -interactive
2017-03-17 14:32:04 [Jazz build engine] Running build loop...
2017-03-17 14:32:04 [Jazz build engine] Waiting for request...

Thank you

Ralph Schoon selected this answer as the correct answer

Comments
Ralph Schoon commented Mar 28 '17, 7:43 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Your answer


Register or to post your answer.