It's all about the answers!

Ask a question

Unable to connect RTC to jenkins

Lokesh Sreedhara (623) | asked Apr 13 '14, 12:52 a.m.
edited Apr 13 '14, 12:54 a.m.

I am trying to set up a Jenkins Build engine in RTC and unable to do so due to the follwoing error:
THis error comes up when i enter the hostname and port of jenkins in RTC and test the connection.
Connection test requested.
    Connection test requested.
    Connecting to:
Exception: connect timed out    Test connection FAILED!

I have looked at all the posts here which talk about this error but still unable to get it to work !

I am able to Access the Jenkins Dashboard through the browser, i can also connect to RTC from the Jenkins Config settings. But not able to Do it the other way around from RTC.

To add to This i cannot access the jenkins Dashboard outside of my VM. I am guessing This is the issue ! How do i fix this ? Would require your experties on this.

My system Setupl
OS: RHEL 6 on Virtual Machine
RTC: 5.0 M4
RTC Build kit: 5.0 M4
Jenkins: 1.532.3
RTC Plugin: Team Concert Plugin 1.0.12

Trouble shooting steps done so far:
1. Added port 8080 to RHEL firewall
2. Added a String property in the RTC build engin for with a value of 1000
3. Added Forward ON in iptables

Would be extremely useful if you guys could help me out, Thanks in advance


sam detweiler commented Apr 13 '14, 7:05 a.m.

at least on my server its http://server:port/jenkins/

note the 'jenkins/'

the trailing slash matter for job starting

Lokesh Sreedhara commented Apr 13 '14, 11:03 a.m.

Hi sam,

Thanks for your Reply, I tried this and wont still work !

sam detweiler commented Apr 13 '14, 12:34 p.m.

what is the URL for the jenkins homepage? does it come up?

Lokesh Sreedhara commented Apr 13 '14, 12:47 p.m.

Yea, The jenkins dashboard/homepage shows up only in the VM at 

But cannot access the homepage outside of the VM. I get the a Time Out error in the browser.

sam detweiler commented Apr 13 '14, 12:51 p.m.

this seems like a networking issue related to the Virtual machine.

Lokesh Sreedhara commented Apr 13 '14, 7:41 p.m.

Yea, i guess . The VM on it own works fine.. not sure. the 8080 is open, still no results.

showing 5 of 6 show 1 more comments

One answer

permanent link
Abraham Sweiss (2.4k1131) | answered Apr 24 '14, 5:00 p.m.
Get the IP of the VM and then in the client machine, map to the IP in the host file to see if that makes a difference

Your answer

Register or to post your answer.