It's all about the answers!

Ask a question

RTC 4.0.4 P2 Repository support for RAD9.0

Martin Dam Pedersen (1352814) | asked Nov 18 '13, 7:59 a.m.

We are having trouble using the P2 repo client when installed into RAD9.0
Whenever we select the pending changes view, RAD crashes.

This is what we do:
1. install RAD9.0 32bit via the installation manager on a windows 7 machine
2. install into RAD via Help->Install New Software...
3. when the installation is finished, RAD is restarted
4. In RAD select Window->Show View->Pending Changes
5. RAD crashes

Any recommendations on how to get RTC client working with RAD9.0 would be appreciated.

2 answers

permanent link
Lara Ziosi (33811112) | answered Nov 18 '13, 8:09 a.m.
RAD v9 is based on Eclipse 4.2.
RTC started to have an Eclipse 4.2 client in version 4.0.3.
I recommend that you download the Client for Eclipse IDE 4.2 from the RTC 4.0.4 download list, and that you install it using IBM Installation Manager, selecting the same package group where you have already installed RAD v9.

Lara Ziosi commented Nov 18 '13, 8:13 a.m.

It might be wise to troubleshoot the crash.
You could post the files:
(where eclipse.exe is)

Martin Dam Pedersen commented Nov 19 '13, 2:57 a.m. | edited Nov 19 '13, 2:58 a.m.


Tried installing as proposed by Lara Ziosi, but that doesnt solve the problem.
RAD still crashes when opening the pending changes view.

I would love to post the log files, but how do I attach a txt/log file to this thread ?

Lara Ziosi commented Nov 19 '13, 3:07 a.m.

An issue with similar symptom has been reported to support and is under investigation. To confirm it is indeed the same issue, could you please upload:
(where eclipse.exe is) . These files are created when the product crashes.
workspace.metadata.log  (This refers to the workspace location you used when the product crashed).
Thank you and regards, Lara

Martin Dam Pedersen commented Nov 19 '13, 3:28 a.m.

Lara Ziosi commented Nov 19 '13, 3:58 a.m.

Hello Martin,

Thank you for opening the WorkItem. The JavaCore shows that the crash is a Global Protection Fault in the module:


which belongs to the IBM JVM, version 1.7 SR4 FP1:

1CIJAVAVERSION JRE 1.7.0 Windows 7 x86-32 build 20130306_140761 (pwi3270sr4fp1-20130325_01(SR4 FP1) )

These details correspond to an existing PMR, that has been sent for investigation to our JVM developers.

To complete the investigation, in the currently open PMR we requested a System Core (which is always needed to troubleshoot a crash in a native dll).

It could be that we do not need a new System Core from you, as probably the root cause will be the same defect in both circumstances.

If you need a fix for this before a next release, I recommend that you open a support case and reference this thread and the WI you opened, as we cannot deliver fixes via the forum.

Thank you and regards, Lara

Lily Wang commented Nov 20 '13, 11:01 p.m.

Hi Martin,

I met the same issue.
It's fixed using the workaround provided in
The crash is not happened after I removed line:
from eclipse.ini

showing 5 of 6 show 1 more comments

permanent link
Martin Dam Pedersen (1352814) | answered Nov 26 '13, 9:59 a.m.
"Workaround 2: Modify eclipse.ini" from also solved the problem for us.

Your answer

Register or to post your answer.