It's all about the answers!

Ask a question

access denied to selected files in a stream. how to debug?


sam detweiler (12.4k6175200) | asked Feb 06 '14, 6:42 a.m.
edited May 23 '16, 10:26 p.m. by David Lafreniere (4.4k7)
after our migration this last weekend, one user cannot access all the files in a stream.
two files in one folder in one component.  the migration was from 3.0.1 to 4.0.4

I can see them all and open them without trouble.

the stream is owned by the project,
and the components are also owned by the project
the files in the component show project and team owernship. and the user is a member of the team with source access rights (Team Member, out of the box configuration).

I have set the permission to component, and back to project/team. with no change.

the two files are way down the component file tree.

in 4.0.4, one file shows but reports does not exist when open is attempted,
the other file does not appear
using  3.0.1 he gets access denied. (and 4.03  ont he web ui)..

the upgrade was indirect. 3.0.1 to a middle box, streams and workspaces were duplicated/copied
the middle box was upgraded to 4.0.4 and then the streams and workspaces were duplicated/copied
to the production machine.

there were difficulties copying the streams 4.0.4 to 4.0.4 with both the api and the eclispe ui.
they reported the copy failed, but the stream was in fact present and appears to be accurate for everyone
we created a new workspace from it, and compared to the last workspace used by build on friday afternoon,
and the workspaces compare ok.

any suggestions on how to debug this?



Comments
Krzysztof Kaźmierczyk commented Feb 06 '14, 6:59 a.m.

Hi Sam,
What do you mean  by access denied? Do you have any error message? What are you alredy doing and what is your error message?


sam detweiler commented Feb 06 '14, 7:33 a.m.

Eclipse says 'Access denied'
the web says the file is not present or you do not have access
  (after presenting the file name in the ui)

the 4.0.4 web says error 403 Access denied.

I can post parts of screen shots later when I get to the office.

Accepted answer


permanent link
sam detweiler (12.4k6175200) | answered Feb 10 '14, 6:29 p.m.
 this turned out to be a bad Stream, resulting from and error during  the Duplicate function.
a new copy works. 
David Lafreniere selected this answer as the correct answer

One other answer



permanent link
sam detweiler (12.4k6175200) | answered Feb 06 '14, 8:33 a.m.
 here are the screen shot extracts  4.0.4 Eclipse P2, and 4.0.4 web UI

user selecting the file as shown in the eclipse UI, Stream ->show repository files,-> navigate to a folder in a component

results of open file action


web ui. same operation .  note that one file is not even shown ClusterResults.java

Your answer


Register or to post your answer.