It's all about the answers!

Ask a question

Why is the project name being ignored during load?


Vince Thyng (13723052) | asked Feb 04 '14, 7:41 p.m.
When I load eclipse projects in to the default workspace location, the name of the eclipse workspace seems to be ignored.  Instead the name of the component is used.  For example if the component name is 'api_tests', but inside the .project file the project name is actually 'API_Tests'.

When I load eclipse projects in to a non default folder, the eclipse project name is used from inside the .project file.

I have reproduced this with RAD 8.0/RTC 4.0.2 libraries, Basic RTC/Eclipse 4.0.2, and Basic RTC/Eclipse 3.0.1.6 ifix1.
Could someone please explain why this is happening?
I am curious if this is eclipse or RTC that is being inconsistent.

Comments
Donald Nong commented Feb 06 '14, 12:01 a.m.

I don't quite understand what the problem is. What is the "component"? Do you mean the archive name? In RTC or standalone Eclipse, if I import "existing projects into workspace", the project name (as in the .project file) always show up as is.

Maybe you can make a step-by-step to let others understand a bit better?

One answer



permanent link
Vince Thyng (13723052) | answered Feb 06 '14, 12:54 p.m.
Hi Donald, thank you for taking an interest in this topic!

For this example I am using a component name of 'widgets'.
Load the component and select 'Load the root folders of the components as projects'.  
Select the box next to widgets and ensure the sandbox will be loaded in to the default eclipse workspace folder under Advanced Options.

You will now see a project under Navigator view and Package Explorer view named 'widgets'.
Rename the project to 'Advanced Widgets' by right clicking on the project name and selecting rename.
Check in and deliver the .project file.

Unload the repository workspace, delete contents
Load the 'widgets' component again.
Select 'Find and load Eclipse projects'
Ensure 'widgets' is selected and ensure the sandbox folder is still set to the default eclipse workspace folder under Advanced Options
Look in the Navigator or Package Explorer view and find that the project name is 'widgets', not the expected 'Advanced Widgets' that we had just renamed it to.

Open the .project file and you will see the name is still set to 'Advanced Widgets'


What I experienced in a different stream with my exact same client, is that if I specify a different sandbox folder, the name did load correctly.  However while writing up these recreation steps, even the instructions below still load the project name as 'widgets'

Unload the repository workspace, delete contents
Load the 'widgets' component again.
Select 'Find and load Eclipse projects'
Ensure 'widgets' is selected and change the sandbox folder to an alternate location than the default eclipse workspace folder under Advanced Options
Look in the Navigator or Package Explorer view and see what the project name is 'Advanced Widgets' or 'widgets'.

Your answer


Register or to post your answer.