It's all about the answers!

Ask a question

Why is my Test Case Duplication Activity Failing?


Paul Spalitta (8142836) | asked Jan 22 '14, 6:09 p.m.
edited Jan 23 '14, 9:18 a.m. by Max Bridges (24126)
I selected to duplicate 912 Test Cases from the Test Case List View but I received the following error:

Does anyone know why this error occurs?

System Environment:
RQM 4.0.3
DOORS 9.5.1
Using OSLC links between RQM and DOORS (migrated from RQMi)

Accepted answer


permanent link
Vidya Malkarnekar (1.0k15) | answered Jan 23 '14, 9:54 a.m.
JAZZ DEVELOPER
Check if the Test Script mentioned in the error has an attachment. I can reproduce  the error in 4.0.3 when copying a Test case which has Test script with attachment and choose "duplicate with copies" option. You may be running into defect can not make copy of test script snapshot when there is attachment(103237). The defect is fixed in 4.0.6.
Paul Spalitta selected this answer as the correct answer

Comments
Paul Spalitta commented Jan 23 '14, 10:52 a.m.

Defect 103237 appears to the issue. Thanks.

2 other answers



permanent link
Reshma Ratnani (1.1k1) | answered Jan 23 '14, 6:36 a.m.
JAZZ DEVELOPER
Do you get same error when you duplicate a single testcase? If not then can you try to duplicate 5 testcases and see if you get same error again?

You can also try to duplicate just "BDI Import MLC Measured Beam Data Files"  testcase and see if you get same error again

Thanks

permanent link
Sunil Kumar R (1.1k12143) | answered Jan 23 '14, 6:44 a.m.
JAZZ DEVELOPER
 Hello! The error message states failed to copy, its possible that the action of duplication of artifacts in destination project fails.

Please check the following:-

a. Where are you duplicating the test cases? into the same project area / different project area?

b. Check the role the user has? normally users with "TestTeamMember" are better placed to perform such activities since they have R/W permissions.

c. If the failure is copy between projects:
 -- Check the role the user has in destination project (let it be same as source project area)
 -- Check permissions : under QM > Admin > {Project Area} > Permissions : "Check" or provide permissions for all "Save" actions for the role (role assigned to the user) as highlighted below..


d. Check on different (supported) browser?

e. Try on different project areas (if feasible) and re-do steps a-d.

If none of the above work, we need to debug using the logs / perform some troubleshooting on the web client and I suggest you can raise an IBM Support Request.

Best Regards, Sunil

Your answer


Register or to post your answer.