It's all about the answers!

Ask a question

RTC Web UI cannot display the right information at once


Kenery Wang (6411524) | asked Jan 16 '14, 10:04 p.m.
edited Jan 16 '14, 10:06 p.m.
Hi everyone,

I've been encountering an uncomfortable using experience on RTC Web UI, hope you guys can help me on improving this issue.

My environment is:
  • Windows 7
  • Browser: IE v11, Chrome v32 (Both can duplicate the issue.)
  • RTC v4.0.3
The scenario is, when I try to access a work item which I've created before, get into the approval page, then all the approvals which should be displayed on the approved section are gone, I mean, the approved section is turned into EMPTY.

So I just REFRESH the web page, then all the approvals are all coming back. Even it can work though but it's not convenience for me to refresh the web page again and again...

Is there anyone can explain what is going on my RTC Web UI? 
Is there any way to find the root cause (Some other softwares help on debugging?) and improve it?

Thanks for all your help in advance.

Kenery



Comments
Simon Washbrook commented Jan 17 '14, 2:49 a.m.

Hi Kenery,

Both are your web browsers are not supported (IE V11 and Chrome v32) see the system requirements for your version:
https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements403#B2_Browsers

Can you try to reproduce the issue in a supported browser?
if you can then this will eliminate the browser version as a possible cause. There are known issues with IE v11 which is why it is not yet supported in the latest versions of RTC, only IE v10 is supported by the 4.0.5 version.

Simon

2 answers



permanent link
Adam Wereszczynski (92811532) | answered Jan 17 '14, 2:24 a.m.
edited Jan 17 '14, 2:32 a.m.
Hi Kenery,

IE11 is not supported with RTC 4.0.3. But Chrome is.

Both IE11 and Chrome come with developer tools preinstalled which can help you troubleshoot this issue.
I don't have IE11 at hand to check the appropriate option, but for Chrome you can go to Tools -> Developer Options.

Before reproducing the problem, please enable debugging of RTC Javascript.
To do that, you need to add additional ?debug=true parameter to the URL before first "#" sign or at the end if this sign is not in the URI.

For example if you are on RTC dashboard - https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.dashboard.viewDashboard

You must change it to https://jazz.net/jazz/web/projects/Rational%20Team%20Concert?debug=true#action=com.ibm.team.dashboard.viewDashboard

The debug switch slows down browsing and will remain active until you remove it from URL or browse to a different application (like /qm, /jts).

Now, please reproduce the problem and notice any messages in the Console and Network tab.
If you have such possibility, please paste screenshots and error messages here.
If you feel that this reveals too much proprietary information, I suggest that you open a PMR and continue working on this case with RTC support.

permanent link
Scott Cowan (966310) | answered Jan 17 '14, 10:46 a.m.
JAZZ DEVELOPER
Hi Kenery,

Do you face the same problem on our self-hosting 4.0.6 M2 install?  Here's an example build tracking work item with several approvals.  I can see the approvals fine in Chrome 32.

https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=287853&tab=com.ibm.team.workitem.tab.approvals

Scott

Your answer


Register or to post your answer.