It's all about the answers!

Ask a question

JBE not picking up builds after JTS restart


Karthik Krishnan (859498142) | asked Nov 14 '13, 2:51 p.m.
When the JTS is restarted (unplanned restart,ex: outofmemory error ), the JBE doesn't process the builds anymore. Only way is to restart JBE after JTS restart. This is causing so much trouble for us. Is this normal behavior or RTC & JBE?

Any workaround for this ?  

We are on RTC 4.0.2

Comments
Spencer Murata commented Nov 14 '13, 2:57 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

 The JBE should continue to run against the JTS even if the server is down.  Are you sure that the JBE is still running?  Check the output from the JBE and make sure its still polling the server.


~Spencer 


Karthik Krishnan commented Nov 15 '13, 5:08 a.m.

Yes I am very sure that JBE is/was running. We have many JBE's  running on different machines and all result in seeing same behavior. 


Karthik Krishnan commented Apr 04 '14, 7:34 a.m.

We are facing this from RTC 3.0.1, RTC 4.0, RTC 4.0.2, RTC 4.0.5 


Anyone else facing this issue?


1
Arne Bister commented Apr 04 '14, 10:35 a.m.
JAZZ DEVELOPER

Karthik, at any rate please open a jazz.net work item against this so the team can track it. My thoughts initially are that this is unexpected behavior.
JBE is basically running a headless Eclipse, logging in against the server with the ID of the build user. Now if a server goes down with my regular Eclipse client and gets restarted, I do expect my Eclipse to pick this up after a while and reconnect to the restarted server. Maybe it is naive to assume JBE does the same but it would be surely what I expect as an end user.
Please send me WI link once you got it.

Best,
Arne


Be the first one to answer this question!


Register or to post your answer.