It's all about the answers!

Ask a question

RQM Excel Importer Bad Request


d B (111) | asked Nov 04 '13, 4:03 p.m.
hello,
i am trying to export some lab resources provided in an excel file via the excel importer. Exporting to xml files works like a charm for me, but uploading data to my jazz.net sandbox ends up in bad requests. I am following the steps described in the excel importer wiki. Exporting with a unchecked box ("link to existing RM requirement") causes the already alluded error code 400.

log file:
11/4/2013 2:27:23 PM: sending labresource12 named DevOpsMgmt_HW_Extract_Sheet1_13.xml

11/4/2013 2:27:24 PM: ERROR: <Unknown Caller Context>: RQMConnector: PutToServer - Error putting resource: https://jazz.net/sandbox01-qm/secure/service/com.ibm.rqm.integration.service.IIntegrationService/resources/bortmesd%2527s%2bProject%2b%2528Quality%2bManagement%2529/labresource/XLS/XLS/DevOpsMgmt_HW_Extract_Sheet1_13.xml

May anyone please help me in order to get the exports uploaded.

Dominic


Comments
d B commented Nov 05 '13, 6:37 a.m. | edited May 12 '14, 7:26 p.m.

hey, thanks for answering,
i am using the provided "lab resourecs.xls" with the standard config file.The role "test team member" has been assigned to the account.
i can't even export this file:
http://bit.ly/174g0T2

btw: the importer recognizes my credentials as valid and detects all project areas properly.



Don Yang commented Nov 06 '13, 1:02 a.m. | edited Nov 06 '13, 1:09 a.m.

there are some important info not in the discussions:
version of RQM used, version of ExcelImporter used, OS you run and what sample files used and what you want to achieve as the result of export.


1
d B commented Nov 06 '13, 2:30 a.m.

sorry, here is is my system configuration
jazz sandbox1: RQM 4.0.5
jazz sandbox2: RQM 4.0.4
Excel Importer: 4.0.4
i am currently running win7 64 bit professional with sp1

my goal is to import approx. 400 lab resources from a excel file into rqm, and test the usabilty of the lab management module in rqm.
yesterday a colleague claimed that the excel importer may not be able to handle the jazz.net addresses because of the amount of redirects.. As my log file says:

Proxy Error: Host connected but unable to forward request "https://199.246.40.115/sandbox02-qm/secure/service/com.ibm.rqm.integration.service.IIntegrationService/resources/..


Sunil Kumar R commented Nov 06 '13, 4:39 a.m.
JAZZ DEVELOPER

Hello! yes I see the same error while using the excel exporter utility and similar behavior as well.


I found an alt., mechanism to upload data using RESTClient! But dont think its practical to use the client to create 400 artifacts.. Do you perhaps have an automation tool available - that might help in this activity.

Best Regards, Sunil

2 answers



permanent link
Sunil Kumar R (1.1k12143) | answered Nov 05 '13, 3:07 a.m.
JAZZ DEVELOPER
 Hello!

At first glance the error appears to be occuring due to malformed URL used with POST for the XML resource indicated.
But it's hard to figure out what exactly went wrong without the specifics (sheet, config file, logs)

So I would like to propose teh following way to help troubleshoot this issue:-

a. Try using the "Lab Resources" sheet and config file provided in RQM excel exporter samples.
b. Assign the user the "TestTeamMember" role on the project area, after adding the user under "Members" list for the project area

If the above works, please compare your sheet with the sample and see if there is any commonality and anything specific that is specific wrong in the sheet you use? I know its hard to figure out - but if you are stuck at this point, please contact IBM Rational Client Support with all details available to speed up resolution.

Best Regards, Sunil

permanent link
Miles Thompson (1813) | answered Dec 04 '13, 1:15 p.m.
I have the exact same issue in my thread: https://jazz.net/forum/questions/132735/rqm-404-excel-importer-error-400-bad-request-when-importing-to-sandbox-repository

At first I had solved it by going over http rather than https, but that solution stopped working almost immediately.

Your answer


Register or to post your answer.