It's all about the answers!

Ask a question

Users from active directory group do not have access


Sripriya Karimpuzhasriram (123952) | asked Oct 30 '13, 11:30 p.m.

We are using RAM 7.5.0.2. We are adding users from an Active Directory Group. In the "Users" tab, for a user group, we clicked on "Create" public group and added an Active Directory Group. The Group members automatically populated showing the list of users in that group.

Suddenly one day, though the user group has the active directory group associated with it, the group members table is empty.

Please click on the link below to see the screenshot.

Link

It is sporadic. Though we can see the users the moment we add it, after a few days the users go missing but the active group is still here.

Any idea why this may be happening?

Thanks much for the help!


Comments
Sripriya Karimpuzhasriram commented Oct 31 '13, 12:45 a.m.

When I log in as the Repository Admin, in the Tools page, under "Custom Group and User Information", I see a button called "Update Users and Groups".  I referred the IBM help documentation Administering > Administering Rational Asset Manager > Administering the repository . Would clicking this button help? Would this have any other consequence on the current functionality of the system , lifecycle configuration communities, users in user groups etc..

Thank you!

Accepted answer


permanent link
Rich Kulp (3.6k38) | answered Nov 01 '13, 10:07 a.m.
FORUM MODERATOR / JAZZ DEVELOPER
Once a week the users and groups are synced up with the registry that is configured in RAM. Usually this is on a Saturday (the default setting). If for some reason the group is coming up empty on Saturday then it will set to be empty.

The "Update Users and Groups" button simply kicks of this sync job immediately instead of waiting for Saturday.

There may be errors in the log explaining why the group is empty if an error occurred during the synchronization.
Sripriya Karimpuzhasriram selected this answer as the correct answer

Comments
Sripriya Karimpuzhasriram commented Nov 01 '13, 11:53 a.m.

Thanks Rich! That worked!

Your answer


Register or to post your answer.