It's all about the answers!

Ask a question

Nullpointer exception when opening a plan

Jorge Valdeiglesias (541623) | asked Oct 15 '13, 5:26 p.m.

We are having an issue with one of our clients located in Sweden. They get a nullpointer exception when trying to open the Backlog plan of their proyects.


sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)







$Proxy857.getPlanItems(Unknown Source)

sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)













From our location (Latin America) we had issue only in one of their plan and in the eclipse client (we can open it in the Web UI). The error is:

An error occurred while executing the operation. See the error log for details.

CRJAZ0586I Query is too complex (14391 parameters).

We are using RTC 4.0.3 with distributed topology.

What calls our attention is that we an open the plans normally in the Web UI but they can't.

Is it possible that this is due to the delay they have? (approximately 4.5 secs while we have 0.5 sec for a simple request)

3 answers

permanent link
Aradhya K (1.4k44345) | answered Oct 16 '13, 12:37 a.m.
Null pointer exception when creating a plan (265560) is the defect as part of which this issue is resolved.
The issued is fixed in 4.0.4 so if you upgrade to 4.0.4 your problem will be resolved.

permanent link
Dinesh Kumar B (4.0k413) | answered Oct 16 '13, 2:35 a.m.
the trace shows Null Pointer Exception in fetching plan view... i would suggest reviewing the plan views and removing any invalid plans that are listed.

1.  Go to Plan Views in Eclipse Client
Open PA in Eclipse Client > Project Configuration > Configuration Data > Planning > Plan Views
2.  Delete any view which appears with an exclamation mark against it.
When you select a view > If the Details shows OK to use this View > that view is fine.
For a view with an exclamation against it, you will not see OK for its details.
3.  Now, check if the troubled plan loads fine.

Caution: Deleting such a invalid view will remove it from the repository and hence will be lost.  However, since you are anyways not able to use that view (as its possibly corrupt due to some unexpected modification), deleting such a view will leave you will atleast a useable plan.

hope it helps.

Jorge Valdeiglesias commented Oct 16 '13, 8:33 a.m.

Hi thanks for the quick answer. We checked the views and they are all valid, there is no warning on any of them.

But what you are saying at least gives me a clue on where to keep digging (plans views).

Also, why do you think may be the reason I can open the plans normally but they don't?

Dinesh Kumar B commented Oct 16 '13, 8:38 a.m.

i am not sure i understood correctly, let me clarify first, the question i have is :
do you see that
      a plan opens fine for some users in Web UI
      the same plan gives the error trace shared above for some other users?

Jorge Valdeiglesias commented Oct 16 '13, 1:46 p.m.

Yes, the 1st stack trace is an error reported by several users from the web UI when they try to open a backlog. When I tried to open it, it worked fine (we even did it at the same time during a conference call)

permanent link
Dermot Judge (111) | answered Jan 11 '14, 1:12 p.m.
Our RTC is on 4.0.3.
I am seeing this issue and others also see it sometimes.
I tried the workaround suggested by Dinesh (found a bad plan view and deleted it)
and for now I can now load a plan OK.
Hopefully it stays like that (and hopefully we are moved to 4.0.4 soon).

Your answer

Register or to post your answer.