It's all about the answers!

Ask a question

IBM Http server will not start, port 443 is not listening


Daniel W (131710) | asked Oct 10 '13, 3:12 p.m.
check the syntax by running apache -t in windows.
Got this warning.
" [notice] Disabled use of AcceptEx() WinSock2 API"

But still the syntax is OK.
When I type command apache -k start, script went away looking like it's started.
But it didn't because port 443 is still not listening.

Accepted answer


permanent link
Abraham Sweiss (2.4k1131) | answered Oct 11 '13, 8:04 a.m.
Change the location of the keystore to c:\temp and test.


Daniel W selected this answer as the correct answer

5 other answers



permanent link
Abraham Sweiss (2.4k1131) | answered Oct 10 '13, 7:58 p.m.
Review the error.log to see if there are any indications of problems.  Also check the httpd.conf to validate that there is a virtual host or listen statement which uses port 443.  
The other thing to check is run netstat -an before starting the server to see if there are any other processes listening on port 443

permanent link
Daniel W (131710) | answered Oct 10 '13, 11:45 p.m.
Other than the following, there is nothing else was added to the httpd.conf file.
#########################
ServerName clmserver.fxgovt.com:80

LoadModule ibm_ssl_module modules/mod_ibm_ssl.so
Listen [::]:443
<VirtualHost *:443>
SSLEnable
</VirtualHost>
KeyFile C:/Program Files/IBM/HTTPServer/ihsserverkey.kdb
SSLDisable
#########################

Here is the error log. But key files are in place. At least from the look of it in the directory. I did run netstat, and couldn't find any 443 port listening.

[Thu Oct 10 14:23:55 2013] [notice] IBM_HTTP_Server/8.0.0.3 (Win32) configured -- resuming normal operations
[Thu Oct 10 14:23:55 2013] [notice] Server built: Mar  7 2012 18:34:59
[Thu Oct 10 14:23:55 2013] [notice] Parent: Created child process 5124
[Thu Oct 10 14:23:55 2013] [notice] Disabled use of AcceptEx() WinSock2 API
[Thu Oct 10 14:23:57 2013] [error] SSL0169E: Keyfile does not exist: C:\\Program
Configuration Failed
[Thu Oct 10 14:23:57 2013] [crit] (OS 1813)The specified resource type cannot be found in the image file.  : master_main: create child process failed. Exiting.
[Thu Oct 10 14:24:27 2013] [notice] Parent: Forcing termination of child process 36 
[Thu Oct 10 14:53:46 2013] [notice] Using config file C:/Program Files/IBM/HTTPServer/conf/httpd.conf 
[Thu Oct 10 14:53:46 2013] [notice] IBM_HTTP_Server/8.0.0.3 (Win32) configured -- resuming normal operations
[Thu Oct 10 14:53:46 2013] [notice] Server built: Mar  7 2012 18:34:59
[Thu Oct 10 14:53:46 2013] [notice] Parent: Created child process 2056
[Thu Oct 10 14:53:46 2013] [notice] Disabled use of AcceptEx() WinSock2 API
[Thu Oct 10 14:53:48 2013] [error] SSL0169E: Keyfile does not exist: C:\\Program
Configuration Failed
[Thu Oct 10 14:53:48 2013] [crit] (OS 1813)The specified resource type cannot be found in the image file.  : master_main: create child process failed. Exiting.
[Thu Oct 10 14:54:18 2013] [notice] Parent: Forcing termination of child process 36 


permanent link
Daniel W (131710) | answered Oct 11 '13, 9:30 a.m.
used ikeyman to changed location to c:\temp

but still got this error.

[Fri Oct 11 09:28:24 2013] [notice] IBM_HTTP_Server/8.5.0.0 (Win32) configured -- resuming normal operations
[Fri Oct 11 09:28:24 2013] [notice] Server built: Mar  7 2012 18:34:59
[Fri Oct 11 09:28:24 2013] [notice] Parent: Created child process 4500
[Fri Oct 11 09:28:24 2013] [notice] Disabled use of AcceptEx() WinSock2 API
[Fri Oct 11 09:28:26 2013] [error] SSL0169E: Keyfile does not exist: C:\\Program
Configuration Failed
[Fri Oct 11 09:28:26 2013] [crit] (OS 1813)The specified resource type cannot be found in the image file.  : master_main: create child process failed. Exiting.


Comments
Daniel W commented Oct 11 '13, 9:36 a.m.

I forgot to change in httpd.conf.
It looks like 443 is now listening.
 TCP    [::]:443               [::]:0                 LISTENING


permanent link
Daniel W (131710) | answered Oct 11 '13, 9:37 a.m.
Do you know why it doesn't like the Http server root directory?


Comments
Abraham Sweiss commented Oct 11 '13, 9:51 a.m.

It is either a permissions issue where the user running the web server does not have permission to access that directory or most likely the space in the path.  try putting  quotes around the path.


permanent link
Daniel W (131710) | answered Oct 11 '13, 9:43 a.m.
For some reason, I can ping the clmserver, but I can't see the webpage.
I was doing this only on the server box.

Comments
Abraham Sweiss commented Oct 11 '13, 9:53 a.m.

I need more details on the topology.  And since we got past the port 443 issue and now moving on to a new topic, may be a good idea to open a new forum question

Your answer


Register or to post your answer.