It's all about the answers!

Ask a question

issue to generate table of content with RPE from RQM


David MICHEL (1471944) | asked Oct 02 '13, 9:41 a.m.
Hello,
     I make a template with RPE 1.2 with RQM 4.0.3 as DataSource.
In this template, I insert a table of content but when I generate the word document this "object" is not in it but it's in the html generation.
I generate the report after creating a report ressource in RQM.

Does anyone know how to have a table of content in a word report ?

Thank you in advance

Best regards

Accepted answer


permanent link
Abish Mathew Zachariah (252211) | answered Oct 03 '13, 12:18 a.m.

Hi David

RPE uses Word fields to populate TOC. As you might have noticed in Word, you need to update these fields to populate the information in the resultant document. Can you perform the below steps and see if it help?

- Open the Word output, select all the contents (Ctrl+A), right click and select “update Fields”. This should ideally populate the TOC.

This step can be automated using a macro which can update this field after document generation. RPE provide such a macro and it is contained within the “ rpe.dot” stylsheet (.dot) present in the folder “%RPE_HOME%\utils\word” . You can use this .dot file as the stylesheet for the Word output ( Stylesheet property of the Word output in the .dsx file) and mention the name of the macro as “rpe” in the macro property.

Best Regards
Abish M Zachariah

David MICHEL selected this answer as the correct answer

2 other answers



permanent link
David MICHEL (1471944) | answered Oct 03 '13, 5:10 a.m.
Hi,
   Thank you for your answer. Unfortunately, I can't make "update fields" because the "object" table of content is not in the word document generated. It's my issue.
maybe you have another idea ?

Best regards

David

Comments
Abish Mathew Zachariah commented Oct 03 '13, 10:40 p.m.

Hi David

I have had a look at the template that you sent to support. If you select the TOC element in the template and then go to properties > specific, the TOC code is blank. This seems to be the reason why the TOC is not included in the output. Support will soon send you a modified template. Let me know if that works for you.

Best Regards
Abish M Zachariah


permanent link
David MICHEL (1471944) | answered Oct 08 '13, 3:06 p.m.
I didn't make the good operation. I could be use your first answer and now my table of content is update.

Thank you for your help.
David

Your answer


Register or to post your answer.