It's all about the answers!

Ask a question

How to set updateTomcatFiles=no, while upgrading RTC from 4.0 to 4.0.3


Faizal Rahman (821011) | asked Sep 27 '13, 9:46 a.m.

I am upgrading RTC from 4.0 to 4.0.3 version and we are using WAS and not using tomcat.

While running the upgrade script, it's trying to upgrade 'Tomcat' as well. Since the parameter is set as  "updateTomcatFiles=yes". Due to this, i am getting the error as below

CRJAZ2046E By default, the updateConfigurationFiles repotools command updates both the Application and Tomcat configuration files. If Tomcat is not installed, you can choose to only update the application configuration files by specifying the parameter "updateTomcatFiles=no".

How should i set this parameter to 'no'.

Accepted answer


permanent link
Mark Guertin (5867) | answered Sep 27 '13, 10:12 a.m.
FORUM ADMINISTRATOR
From the interactive update documentation (http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html), when you select that you are using a WebSphere Application Server, you'll see the following for step 13 (for both the jts_upgrade.bat/sh and ccm_upgrade.bat/sh):

To upgrade Jazz Team Server, open a command prompt with administrative privileges, go to the JTS_4.0.3_install_dir\server directory, and enter this command:

upgrade\jts\jts_upgrade.bat -oldJTSHome JTS_4.0.0.x_install_dir\server\conf -updateTomcatFiles no

Note that the parameter is not modified in the file, but passed to the file. For more information on the update scripts, see the links on the following page: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/topic/com.ibm.jazz.install.doc/topics/c_upgrade_script_files.html
Faizal Rahman selected this answer as the correct answer

Comments
Faizal Rahman commented Sep 27 '13, 10:32 a.m.

Hi Mark,

    I have passed the value of 'updateTomcatFiles; as you mentioned. It worked.

   Thanks for your support.

 

Your answer


Register or to post your answer.