It's all about the answers!

Ask a question

How OSLC compliant is RTC?


Chris P (111912) | asked Sep 06 '13, 4:24 p.m.
 For some time now I've been developing an OSLC provider using the Eclipse Lyo project and have RTC be a consumer.  I've been able to get the friend set up, add the association, set up the delegated creation and selection dialogs with hurdles here and there (mostly with OAuth).  Now, when I link a "related change request" from a work item in RTC, I'm getting some errors while trying to save "back links".

RTC tries to retrieve the linked resource as "application/application/x-oslc-cm-change-request+json", something that is not available with the Eclipse Lyo toolkit.  Solution: I created a provider to spit out json for this media type.

RTC then tries to find "oslc_cm:relatedChangeManagement" from the retrieved resource... well... this is not part the OSLC specification either... so Eclipse Lyo doesn't help me there either.

Is RTC OSLC compliant for v2?


2 answers



permanent link
Eric Jodet (6.3k5111120) | answered Sep 10 '13, 5:54 a.m.
JAZZ DEVELOPER
 Hello Chris,
not sure if I can answer your question "Is RTC OSLC compliant for v2?"
which might help you here.

When dealing with backlink creation issues in the context of RTC integration,
I also use the CLM Test App - https://jazz.net/wiki/bin/view/Main/L3/CLMTestApp

Hope it helps,
Eric.

Comments
Chris P commented Sep 10 '13, 8:42 a.m.

Eric,


Thanks for the link to CLM  Test App, when I try to invoke the "Change Request Picker" for my linked project, the log indicates that it's opening the link (modal popup), but the URI it's providing has "debug=true&" appended to the end of the selector link:

Opening http://localhost/itsm-oslc-adapter/services/myProvider/changeRequests/selectordebug=true&, size: [850px, 350px]

Is this a bug in the test app?


Eric Jodet commented Sep 10 '13, 8:53 a.m.
JAZZ DEVELOPER

 umm - not sure


is the URL 
selectordebug=true&, size: [850px, 350px]
or  selector?debug=true&, size: [850px, 350px]


Chris P commented Sep 10 '13, 11:24 a.m.

it was the first, but i fixed the issue.  The link for the test widget had debug=true in it, so i removed it and it worked just fine.


permanent link
Chris P (111912) | answered Sep 10 '13, 4:39 p.m.
 Solved my problem by adding the OSLC-Core-Version header with value of 2.0 to my services response.  Not sure if the Lyo project was supposed to do this for me, or if I missed a configuration somewhere...

Comments
Eric Jodet commented Sep 11 '13, 12:26 a.m.
JAZZ DEVELOPER

 Hello Chris,

glad your issue is fixed now.

Eric.

Your answer


Register or to post your answer.