It's all about the answers!

Ask a question

Sync attributes missing in 4.0.0.1?


Susan Hanson (1.6k2190193) | asked Aug 21 '13, 8:53 p.m.

I have moved from 301 to 4001 and I seem to be missing the ability in the Eclipse client to Synchronize attributes.  I followed the steps here: http://www-01.ibm.com/support/docview.wss?uid=swg21372230

using the default ordering so Type is first.  In the picture, they show both Synchroize Attributes and  Change Type ->

I have neither of those.  Is this related to the regression in 4001 around bulk-change of custom attributes (enumeration type)?  Is there any way to sync attributes  in a different way than this?

Susan

Accepted answer


permanent link
Geoffrey Clemm (30.1k23035) | answered Aug 21 '13, 9:27 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Are you sure you are clicking over the Type column?   (You won't get the menu item if you click over a different column).
Also, I prefer to synchronize attributes by using the "Check attributes usage in the repository" action in the Project_Configuration -> Configuration_Data -> Work_Items -> Types_and_Attributes section of the Process_Configuration tab of the project area editor.
Susan Hanson selected this answer as the correct answer

Comments
Susan Hanson commented Aug 21 '13, 10:46 p.m.

Yes, I was clicking on the Icon which indicated the type of work item, so I'm pretty sure i was on the right column.  I know there is a current bug/regression in 4001 (from 301) where you can't right-click and change certain things, like the Created By, which I could do using my 3.0.1 Eclipse client (same user, same project area, same work item).  I have a PMR open for that one, since it affects not only that but also things like custome enumeration attributes.

 

But I hadn't seen the Synch Attributes was also missing and didn't now if it being not there was part of the same bug.

 

I'll try your "check attributes usage" and while it doesn't look like I can do the sync in small batches (all 2919 work items are missing 1 or more attributes it seems), it does look like I can sync them all.  I wasn't going to sync those that were already resolved ... but oh well .. as long as I can get it to work, my tools will stop barfing on the attribute being missing :-)


Thanks!


Geoffrey Clemm commented Aug 21 '13, 11:28 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I'd recommend sync'ing them all in any case ... even the resolved ones, since some future query or report might act strangely when its missing.
Just for interest's sake, what are the top 5 or 6 entries in the menu when you right click over the Type column?   In 4.0.3, they are:

Open



Change Type ->
Synchronize Attributes



Open Context Aware Search
Locate Change Sets
etc. ...

Your answer


Register or to post your answer.