It's all about the answers!

Ask a question

How to start RFT-tests by schedule from QM on remote virtual machine?

igor lyubin (131418) | asked Jul 16 '13, 11:08 a.m.
We coded a number automation tests in RFT. We imported its to QM. And now we want orginize everyday runnings this tests bu schedule.

We have remote virtual machine where we want to start our RFT tests. We connect to this machine by RDP (remote desktop), we start on it adapter as administrator, we start there RFT, then we start run our tests from QM manually. All passed ok!

Now we wanna start scheduling! But in not working. When we close RDP connection, remote machine still work, but tests not running on it!
When test running they return absolutely empty logs.

Please, help. What we made wrong? How to setup start RFT-tests by schedule from QM on remote virtual machine?

Igor Lyubin

Ara Masrof commented Jul 16 '13, 11:24 a.m.


When you say 'When we close RDP connection, remote machine still work"; does this mean that the RFT adapter running on the VM is still listed in the Adapter Console of RQM if you refresh? 


igor lyubin commented Jul 16 '13, 12:07 p.m.

Yes, adapter still running on the VM and listed in the RQM Adapter Console 

2 answers

permanent link
Thomas Suedbroecker (29335) | answered Jul 16 '13, 11:28 a.m.

Hello Igor,

I would say, you have the screen saver switched on, at your remote machine.

If you got logs, maybe you will have the information object not found.

The functional Tester execution needs test objects on the screen and if the screen saver is on and the machine is locked, the test cannot be executed correctly.

Try to switch of screen saver and check what happens.



igor lyubin commented Jul 16 '13, 12:12 p.m.

Screen saver was off. :( And in power manager in windows choosed plan never turn off the display and never put the computer to sleep.

Computer always still alive.

permanent link
igor lyubin (131418) | answered Oct 11 '13, 10:30 a.m.
Any other ideas?

Your answer

Register or to post your answer.