It's all about the answers!

Ask a question

RTC jenkins build engine error

g k (17147) | asked Jun 21 '13, 12:45 p.m.
Everything setup in jenkins and tested on jenkins (rtc plugin, build toolkit etc)
However when it comes to creating the build engine get the following error
When we try to connect we get this error: 

Connection test requested.
Connecting to:
Exception: No Hudson/Jenkins header found! Test connection FAILED!

However, the headers are present on that URL:

any ideas?

5 answers

permanent link
g k (17147) | answered Jun 22 '13, 8:32 a.m.

got it working!!!


instead of:

should have been

permanent link
Josh Crawford (984615) | answered Jun 21 '13, 3:02 p.m.
 Hi GK,  can you connect if you leave the /jenkins off the end of the URL?  Also, what version of RTC are you using?

g k commented Jun 21 '13, 6:36 p.m.

Rtc version 4.3 

I will try that and report back


permanent link
praveen patidar (8613144) | answered Oct 02 '13, 11:50 p.m.

Hi ,

I am able to connect to Jenkins build engine by this resolution.

while trying to get the Job in build def it is listing the jobs as well. but the moment I select the job there is error occurred in the button same can be visible in the build requect error.

If I put only /  it will give me

character reference "&#x1f" is an invalid XML character.

if I provide /? in the URL then jobs are not getting listed. and the error in the button is changes to  

The entity "nbsp" was referenced, but not declared.

Thanks in Advance


permanent link
Zeeshan Choudhry (6541612) | answered Oct 03 '13, 6:12 a.m.
Tested this with RTC 404 and Jenkins1.533
URL used was just address:port
and it works fine connecting to jenkins and also get the jobs listed in Build Def without any error.

Can reproduce the problem you mention if i use

so use

permanent link
Yogesh Goyal (1112) | answered Sep 12 '18, 12:15 p.m.

 Hello Friends,

I have installed RTC as well as Jenkins on my local machine. I tried to connect RTC in Jenkins via its ccm url and it is successful. Now I have created a build engine (Hudson/Jenkins) in RTC and given the jenkins url as http://<IP of my machin>:8080 (without /jenkins in url), but I am getting connection timeout error. However same url http://<IP>:8080 is working in browser and I am able to open jenkins.I have already tried below solution, but none is working. Please help me to resolve this error asap. 
(1) Given localhost instead of IP. But then its giving error localhost cannot resolve
(2) Added "/" one slash at the end or url
(3) Added /jenkins in the url (even though I am able to access jenkins without /jenkins in url), just to give try
(4) changed timeout setting form 30 to 1000 (or even 5000)
(5) Unchecked as well as checked Validate Certificate/URL
(6) Checked as well as unchecked authentication required etc
Below is the version details of Jenkins and RTC
Jenkin - ver 2.121.3
RTC - Version 5.0.2, Build ID RTC-I20141031-0926
Local Machine - Windows10
Error I am facing - Connection test requested. Connecting to:
Exception: Connection timed out (Connection timed out)
Test connection FAILED!
When I hover to yellow trangle, it says "Hudson/Jenkins server may not be present or running". While jenkins is up and running.
After this solution, I need to configure a Job in Jenkins which just pull the source code (not build/compile) at local. So if possible, please help me with the configuration of this "Pull only" job on jenkins too. I have already installed RTC build tookkit in Jenkin. Thanks in advance.

Your answer

Register or to post your answer.