It's all about the answers!

Ask a question

RRDI communicating ports - using 908* ports

Milan Krivic (98013176142) | asked Jun 10 '13, 8:49 a.m.
In our production environment, we have separated DB server where we have installed DB2 ESE and RRDI 2.0.x. 
When we try to communicate with RRDI cognos server from CLM server, we get a message about not displaying page. 
The reason is that we must allow the traffic for both https 9083 and http 9081 ports between CLM and RRDI server because it 's probably issued that CLM server use both ports for communicating with RRDI.

So my question is next:

Is there possible to use only https 9083 port (avoid http 9081) for communicating between two different server like it is our situation?

We have not these problems in pre-production because we have both CLM and RRDI on the same server.

3 answers

permanent link
Indradri Basu (1.8k1514) | answered Jun 10 '13, 9:31 a.m.
edited Jun 10 '13, 1:17 p.m.
Hi Milan, Francesco's suggestion is quite good. Generally, by default, CLM uses HTTPS and RRDI uses HTTP.

9081 is possibly the HTTP_Transport port of Websphere profile that hosts your RRDI application. Now if you have multiple WebSphere profiles hosted on the same server then there is a possibility that 9081 and 9083 are both used by some profile or some applications to receive communication via http.

The quickest way to find which profile is using which port as HTTP_Transport port, is to open the <webSphere Install_dir>/profiles/<profileName>/logs/AboutThisProfile.txt file.

You can change the default HTTP_Transport port from the WebSphere Admin Console and change the Environment details from the cognos configuration. Anyway, if you decide to try all these, ensure you take backups of your websphere profile (using backupconfig.bat/sh) and Cognos configuration as well before making any changes.
Hope this helps a bit.

permanent link
Guido Schneider (3.4k1491115) | answered Jun 10 '13, 9:43 a.m.

My goal was to use the same URI than for the rest of the CLM applications. Just the context root should be /reporting.

So my Reporting Server URL looks as follow:

I did following steps:

  1. Standard installation of RRDI untiul it works perfect
  2. enable Cognos to speech SSL within IBM Cognos Configurator
  3. configure the websphere profile to use SSL
  4. configure the IHS-Plugin to forward the calls to the correct WAS profile on SSL

 I have some personal notes about in addition to the link from Francesco. I have to check them and may post them here.

Indradri Basu commented Jun 10 '13, 1:14 p.m. | edited Jun 10 '13, 1:15 p.m.

Hi Guido, deploying RRDI in a different profile in quite important as you can leverage a separate jvm but I think you need quite good amount of system resources to deploy all in same server.
It would be great if you can post some details about the resources consumption/utilization of your server and I am sure it will be a good reference for all of us.

permanent link
Francesco Chiossi (5.7k11119) | answered Jun 10 '13, 9:00 a.m.
Hello Milan,

I would suggest to have a look at the following info center topic, about enabling SSL for the report server, and see if it helps with your problem:
Enabling secure sockets layer (SSL) for the report server

Best Regards

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.