It's all about the answers!

Ask a question

RTC Client failing to connect to server

Matthew Bradshaw (51315) | asked Jun 06 '13, 10:42 a.m.
Trying to connect the RTC client to jazz and I'm getting this error message.

The server is running and I am logged in as that user in the web so they have the right credentials.  The client is the exact same version as the server (4.0) and I have rebooted everything plus reinstalled the RTC client. 

I have had this working in a different copy of the same VM previously, which is now having the same problem. 

Any ideas?

Karl Weinert commented Jun 06 '13, 11:10 a.m.

What version of Java are you using?
If you are not sure open the eclipse.ini in the install directory
Look for the -vm argument
run java.exe -version against the java.exe in that directory.

Shubjit Naik commented Jun 06 '13, 11:21 a.m. | edited Jun 06 '13, 11:21 a.m.

To confirm, are you logging in through the web on the same machine as the RTC Client?

Since it is the GADO setup, I know we have to add an entry for the hostname and IP in the hosts file.

Matthew Bradshaw commented Jun 06 '13, 11:33 a.m.

It is all on the same machine, apache, web browser and eclipse client.  The host file is configured so points to localhost.

Java version for the eclipse instance is in

C:\IBM\TeamConcert\jdk\jre and it is version 1.6.0

Piotr Aniola commented Jun 06 '13, 11:38 a.m.

Is there an error message/stack trace generated in <workspace>/.metadata/.log file when you are attempting to connect?

Matthew Bradshaw commented Jun 07 '13, 4:11 a.m.

!ENTRY 1 800 2013-06-06 16:21:40.056
!MESSAGE CRJAZ1887I The list of certificates available in the Windows-MY KeyStore could not be read. If you'd like to access the certificates from that key store, make sure that you are running with a JVM that supports reading from that key store.
!STACK 0 Error initializing the key store.

Accepted answer

permanent link
Shubjit Naik (1.5k1613) | answered Jun 07 '13, 5:49 a.m.
Found the following forum topic on the similar error due to the certificates

Click Window>Preferences>General>Security>Secure Storage>Content > expand "Default Decure Storage"and delete the
Try connecting again
Matthew Bradshaw selected this answer as the correct answer

Matthew Bradshaw commented Jun 07 '13, 6:00 a.m.

Thanks, after reading the error log i was pointed to i cleared everything in the stored passwords, turned it off and reconnected perfectly.


Bo Chulindra commented Jun 07 '13, 11:52 a.m.

This is odd, I wonder how the keystore was able to made RTC unable to contact the server. Also, I just now noticed the text in your error dialog. It says something like

Address family not supported by protocol family: connect

2 other answers

permanent link
Piotr Aniola (3.7k11738) | answered Jun 06 '13, 10:52 a.m.
Please try checking if you have any proxies defined in Eclipse:
Window->Preferences->General->Network Connections.

Matthew Bradshaw commented Jun 06 '13, 11:34 a.m.

This is what the network preferences looked like when i opened it

permanent link
Dinesh Kumar B (4.1k413) | answered Jun 06 '13, 11:08 a.m.
Is there a Proxy, you might have to check Eclipse settings in that case.  Preferences > General > Network Connections : here is more help on it -

Your answer

Register or to post your answer.