It's all about the answers!

Ask a question

Unable to start Jazz build engine and showing error that failed to load the JNI shared library.


Sanket Ikhar (1545) | asked Jun 03 '13, 1:24 a.m.
edited Jun 06 '13, 8:38 a.m. by Spencer Murata (2.3k115970)
hi,
I am trying to Jazz build engine but stuck to an error showing that "failed to load the JNI shared library.

Regards,
 Sanket Ikhar

Comments
Josh Crawford commented Jun 03 '13, 7:39 a.m. | edited Jun 03 '13, 7:40 a.m.

 Hi Sanket,  what JDK are you using to start the JBE? Could you post the entire stack trace of the failure?



Sandy Grewal commented Jun 03 '13, 8:42 a.m.
JAZZ DEVELOPER

One possibility is a mismatch of your System and JBE JVM bitness, can you provide more details and the error stack.


Sanket Ikhar commented Jun 04 '13, 1:07 a.m.

Hi,
I am using JDK 1.7.0.40 (64 bit) to start JBE and eclipse client 4.0.1 (64 bit).
the error statement is-
Failed to load the JNI shared library "C:\Program Files\Java\jdk1.7.0_04\bin..\
jre\bin\server\jvm.dll".

 thanks,
Sanket

Accepted answer


permanent link
Piotr Aniola (3.7k1637) | answered Jun 04 '13, 7:14 a.m.
This issue is typically caused by using 32 bit JVM.
Please make sure C:\Program Files\Java\jdk1.7.0_04\bin\..\jre\bin\server contains a 64 bit JVM.
Also, make sure eclipse.ini points to this JVM (the -vm argument).
Sanket Ikhar selected this answer as the correct answer

Comments
Sanket Ikhar commented Jun 05 '13, 2:25 a.m.

Dear Piotr, 

 Thanks for the answer. I am using JVM of 64 bit and i checked eclipse.ini file, it has -vm argument.
But still same error is reflecting.
 


Piotr Aniola commented Jun 05 '13, 3:53 a.m.

perhaps the -vm argument is in the wrong place of the file?
Please post your eclipse.ini contents.
Also, please share the result of java -version command from the jre/bin directory.

2 other answers



permanent link
Alan Sampson (93729) | answered Aug 16 '14, 3:41 p.m.
JAZZ DEVELOPER
 This tip may also be of assistance: https://jazz.net/wiki/bin/view/Main/JbeOtherPlatforms

permanent link
Christophe Lucas (8624847) | answered Mar 21 '15, 10:20 p.m.
Note that I also encountered this error, and it was fully solved simply by launching the same JBE cmd through a DOS command prompt that I had run/launched *as an administrator* (Windows 7, 64-bit).
The JBE cmd I used:
C:\Program Files\IBM\TeamConcertBuild\buildsystem\buildengine\eclipse>jbe -repository https://jazz-team-server:9443/ccm/ -userId build -pass build -engineId jke.production.engine

Your answer


Register or to post your answer.