It's all about the answers!

Ask a question

How Can I Fix High CPU Usage (Javaw.exe) During RTC Query in eClipse?


Nate Decker (37814561) | asked May 30 '13, 1:55 p.m.

I've searched through Jazz.net for answers to this issue, but couldn't find anyone asking the same question.

When I run a query in RTC which will return a large number of results (e.g., more than 1000), my eClipse client virtually freezes. I can periodically take actions, but the client is essentially unresponsive for several seconds at a time with only brief windows of interactivity. When I look at my running processes, javaw.exe is around 23-24%. Since I'm on a 4 core machine, this means it's essentially maxing out one of my CPUs.

What is causing this and is there any way to avoid it? I had thought that maybe limiting the number of query results in the eClipse client might be a work-around, but honestly it seems like it should be able to easily handle 1500 results. I don't know how to set limits on query results so if that's a viable option I'd be interested in knowing how to do this.

Accepted answer


permanent link
Josh Crawford (984615) | answered May 30 '13, 2:09 p.m.
 Hi Nate,  you might consider giving the eclipse client some additional memory to work with.  You can do so by increasing the -Xmx value in the eclipse.ini.  You might want to start with 512m and increase incrementally to see if it provides some better performance.  By default it's set fairly low depending on the way you've installed you eclipse client. 

[crawfomj@arc eclipse]$ more eclipse.ini
-startup
plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505
-product
org.eclipse.epp.package.cpp.product
--launcher.defaultAction
openFile
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
-vmargs
-Dosgi.requiredJavaVersion=1.5
-XX:MaxPermSize=256m
-Xms40m
-Xmx384m
[crawfomj@arc eclipse]$

Nate Decker selected this answer as the correct answer

Comments
Nate Decker commented May 30 '13, 2:29 p.m. | edited May 30 '13, 5:02 p.m.

 I tried increasing the memory allocation as you suggested and that seems to have improved performance drammatically. Thanks.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.