It's all about the answers!

Ask a question

After accepting change sets, newly created project does not belong to workspace


Alexander Abrashkevich (312) | asked May 22 '13, 6:15 p.m.
edited Aug 02 '16, 7:59 p.m. by David Lafreniere (4.7k7)
Hi,

After accepting a number of change sets, I have noticed that some files (mostly Java and Groovy files) from project P1 were moved to project P2. Project P1 is still used. However, project P2 was not added to my workspace (my change set was integrated into P2 but the files are not tracked anymore in RTC. I can edit them but they are not part of my change set). I have tried to reload the component containing both projects and also the whole workspace several times. It didn't work. Error message was that project "/P1" already exists. I couldn't find any file that would contain this pattern. I tried to delete the relevant directories and reload but it didn't work. I can not bypass this problem. After the reload projects are out of sync and I can not sync then due to the same error. Moreover after reloading the workspace I see more projects that do not belong to the workspace anymore. I would be very very grateful if somebody could help with advise on how to fix the problem. Thank you 

Accepted answer


permanent link
Geoffrey Clemm (30.0k23035) | answered May 26 '13, 7:48 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited May 26 '13, 7:48 p.m.
I assume when you say "project", you mean an Eclipse project (with a .project file in the root directory of the project).  It is true that an "accept" does not automatically import new projects into your Eclipse workspace.

But I didn't understand what you meant by "my change set was integrated into P2, but the files are not tracked anymore in RTC".   Assuming you have checked-in all your changes, I'd suggest unloading the component containing P1 and P2 (I assume P1 and P2 are in the same RTC component), and loading it again.   Is that what you meant by "reload"?

If you are getting the error "project P1" already exists, that probably means that you have two different Eclipse projects named P1 in that component.   To see what exactly is in the component, you can either "show -> repository files" (and use the GUI to browse), or you can use the variant of "load" that says "load files but do not create Eclipse projects" ... then you use normal file system browsing commands (not Eclipse) to see what is in the component.
Alexander Abrashkevich selected this answer as the correct answer

Comments
Alexander Abrashkevich commented May 27 '13, 10:54 a.m.

Hi Geoffrey, thank you for your reply. Yes, in the problem description, I meant an Eclipse project. My files were moved to a new component but when I started to edit them I noticed that they are not being saved into RTC (just locally on the disk). New project was not part of my workspace. I have unload and load a component that contains both projects (old and new) many times as well as unload and load the whole workspace but every time I got an error that resource already exists. I have now more than 100 projects out of sync and can not sync them due to the same error. Now I'll follow your suggestions. Thank you.


Tim Mok commented May 27 '13, 11:31 a.m.
JAZZ DEVELOPER

It sounds like the Eclipse project was moved to another component by someone else. When you accepted the changes, it removed the files from the source component and never loaded them in the target component (or changed the already loaded content's metadata to point to the target component).

As of 4.0, there will be a prompt to the user if there are accepted change sets that have new projects and ask to load them. I assume you're on an older version where the Eclipse client does not have this prompt.


Alexander Abrashkevich commented May 27 '13, 12:20 p.m.

Hi Geoffrey, your advise worked! It was a wrong project name in the .projects for a new component (changed set owner probably just copied the file from the old project). I was able to finally sync all projects. Thank you again for your help.

Your answer


Register or to post your answer.