It's all about the answers!

Ask a question

JTS setup - ORA-00922 error


Georg Kellner (840377108) | asked Apr 23 '13, 9:58 a.m.
We try to set up a new jazz environment with 4.0.2
DB provider is Oracle: Oracle Database 11g Enterprise Edition Release 11.2.0.1.0
OS: Windows 2008

Trying to create the tables via Web results in:
The database creation failed with an exception
com.ibm.team.repository.common.TeamRepositoryException: Sql Exception thrown while testing case sensitivity of the database at ...

Runnung repotools results in:
Sql Exception thrown while testing case sensitivity of the database
The database tables were not created.

In the jts WebSphere log, there is an additional:
Caused by: java.sql.SQLSyntaxErrorException: ORA-00922: Fehlende oder ung├╝ltige Option (missing or invalid option)

Any hints regarding this issue?

greetings georg.

Comments
Georg Kellner commented Apr 23 '13, 10:00 a.m.

Granting dba to the user didn't solve the problem.
Creating a jts environment with 4.0.1 was possible on the same Oracle instance with the same access rights for the oracle user


Piotr Aniola commented Apr 23 '13, 10:10 a.m.

ORA-00922 means there is a syntax error in the SQL statement.
Can you, by any chance, trace what was the statement that caused the error? Perhaps the statement is included in the log after SyntaxErrorException?


Indradri Basu commented Apr 23 '13, 3:22 p.m.

To me, this still looks like permission issue. I would suggest to double check if the dba role is really granted on all the databases.

3 answers



permanent link
Georg Kellner (840377108) | answered Apr 24 '13, 7:40 a.m.
Okay, here is the solution:
We had the oracle user JTS-MASTER with the error messages above.
We created a new one, called JTS_MASTER and everything is fine.

So it's a question of - or _ if you'll get strange errors or not.

greetings georg.

permanent link
Benjamin Silverman (4.1k610) | answered Apr 23 '13, 3:37 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
It looks like someone ran in to the same issue on this post and fixed it using the ALTER statement below:

ALTER USER jazzuser QUOTA UNLIMITED ON jazz_tbs;

If your user was created per the guidelines in the InfoCenter topic "Setting up an Oracle database", it should already have this permission.  Can you confirm?

permanent link
Georg Kellner (840377108) | answered Apr 24 '13, 6:14 a.m.
The trace gives one error:

=====================
PARSE ERROR #3:len=76 dep=0 uid=94 oct=1 lid=94 tim=3063038240487 err=922
CREATE TABLE JTS-MASTER.REPOSITORY_STRING_TEST(TEST_VALUE CHAR(10) not null)
=====================

The dbuser is created as described in the product documentation.

Comments
Indradri Basu commented Apr 24 '13, 6:21 a.m.

Hi George, if you have not already tried this: Add the dbuser to Administrators group and open a command prompt with "Run as Administrator" and then run the repotools command. See if that makes a difference.


Georg Kellner commented Apr 24 '13, 6:26 a.m.

I'm a little bit confused.
How should I add a dbuser defined in Oracle on the db server to the admin group of the JTS server?

Your answer


Register or to post your answer.