It's all about the answers!

Ask a question

RTC Upgrade from v 1.0.1.1 to RTC 4.0.0.1


Neelesh Shukla (1111) | asked Feb 06 '13, 6:49 a.m.
retagged Feb 08 '13, 5:55 p.m. by Amy Laird (16514)

I need to upgrade RTC from version 1.0.1.1 to RTC 4.0.x.

Please advise me, how to go for it.

We have purchased license for RTC 1.0.1.1.  What needs to be done to get RTC 4.0.x.

One answer



permanent link
Ralph Schoon (55.5k23642) | answered Feb 06 '13, 7:28 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Please refer to the product help: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/c_upgrade_overview.html. Run the interactive upgrade guide: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html .

To go from 2.x to 4.x please note:

Upgrading from V2 to V4: Upgrading from version 2 to version 4 is a two-step process. You must first upgrade your server to the latest fix pack of version 3.0.1, then upgrade to version 4.0.1. For instructions to upgrade from version 2 to version 3, see the 3.0.1 information center.
From the documentation of RTC 3.0 I have to assume you have to be at 2.x to upgrade to 3.x: http://pic.dhe.ibm.com/infocenter/clmhelp/v3r0/topic/com.ibm.jazz.install.doc/topics/c_rtc_upgrade_overview.html

Here is the description on how to upgrade from 1.x to 2.x: https://jazz.net/downloads/rational-team-concert/releases/2.0.0.2?p=upgrading

So, as far as I can tell, you have to upgrade from 1.x to 2.x and then to 3.x and then to 4.x.




Comments
Neelesh Shukla commented Feb 12 '13, 6:45 a.m.

Thanks Ralph,

I started working on your inputs. Just one more question. Do I need to purchase each version 2.0, 3.0 and 4.0 seperately. And if so, I have licenses for RTC 1.0 so they should be reused and I should get these installables without purchsing new licence. Am I right??


Ralph Schoon commented Feb 12 '13, 7:12 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Hi Neelesh, if you purchased RTC and have it under maintenance contract, I believe you should be able to download the required licenses from your Passport Advantage site. With maintenance contract you are certainly entitled to it. If they are not available in this case, I would contact support.

If you are using 10 Free developers, you can download them from the download pages for the version to upgrade to.

You will need to upgrade the licenses when going up. The licenses for version N don't typically work for the product version N+x.

Your answer


Register or to post your answer.