It's all about the answers!

Ask a question

The built-in attributes disappeared from the Eclipse

Ana Gonzalez Illescas (2123) | asked Jan 23 '13, 3:48 p.m.

I have been working in the eclipe and all the built-in attributes dissapeared over the weekend. I had a back up of the Process Configuration Source and I even Put a code there of a backup copy of the process configuration from a newly created project and when I saved and went to the Editor Presentation on the Details Section I saw that the attributes are still not there. I will attach an image showing the way I see the attributes now.

Scott Sherwood commented Feb 25 '13, 7:18 p.m.

Hi Ana, I am having the exact same problem!  In both the Types and Attributes tab and the Editor Presentation tab, the built in attributes appear to be missing.  But when I log in using the browser, everything is still there.  Also, if I try to add a new Work Item of the Type in either the Eclipse or Browser UI, all of the built in attributes appear.  I'll try what Scott Crouch suggested on Jan 23.

2 answers

permanent link
Piotr Aniola (3.7k11738) | answered Apr 19 '13, 11:13 a.m.
Two times I seen this so far, the process template turned out to be corrupted. Please have a close look at the initialization actions of the project. You can try exporting the process template, creating a new project using this template, and checking if the project initializes correctly.

This type of problem is typically caused by copying the process configuration source around.

Scott Sherwood commented Apr 19 '13, 11:39 a.m.

Isn't a Process Template just a set of text files?  The primary one being the Configuration Source which is XML?  When you use the term "corrupt", I think of a malformed or unsupported entity/attribute/property in the XML.  Shouldn't this be easy to spot?  What exactly is meant by a corrupt process template?

Piotr Aniola commented Apr 19 '13, 11:43 a.m.

The XML itself may be fine, but referencing a missing entity from outside of the XML.
This is why just copying the XML around is not supported - it doesn't contain all the information.

Scott Sherwood commented Apr 23 '13, 1:35 p.m.

Hi Piotr,
Can you give an example of something in the Process Configuration which is not in the XML?

Piotr Aniola commented Apr 24 '13, 4:28 a.m.

Process attachments.
Have you already tried exporting the template and creating a fresh project area? This is a 10 minute test that would conclusively prove whether the process is corrupted or not.

permanent link
Scott Crouch (48532426) | answered Jan 23 '13, 10:12 p.m.
 If you switch to the process configuration source tab you can right click in the editor and choose history. Then you can see a version controlled history of the config. Perhaps it will provide some insight into what changed? 

Ana Gonzalez Illescas commented Mar 11 '13, 11:50 a.m.

I have the theory that the problem started because I have too many attributes...can this be possible?

Scott Sherwood commented Apr 19 '13, 8:24 a.m.

You mean custom Attributes?  I don't think so, and here is why.  We are having the same problem with one of our PAs.  We use that PA for the development of new templates that we then push out to about 300 project teams.  Now, when we noticed the problem, we checked those PAs and they were all OK.  So, whatever happened to our development PA had not gotten to the project PAs.  We then took a copy of one of those other project area configurations and created a new PA to work from.  The problem did not show up, and we have added more custom attributes to the new PA and even pushed those out to the project PAs without the issue showing up again.
We opened a PMR with Rational and they replied that we had a "corrupted" PA.  Still working that with them.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.